[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xlog-discussion] pkg-config error

From: Alexandru Csete
Subject: Re: [Xlog-discussion] pkg-config error
Date: Tue, 15 Jun 2004 11:51:52 +0200 (CEST)
User-agent: SquirrelMail/1.4.2

Hi John,

> Trying to install xlog-0.9.6 on a Mandrake 9.2 machine and I get the following
> message during configure:
>   checking for gtk+-2.0 >= 2.2.0 libgnomeprint-2.2 >= 2.4.0...
>   Requested 'libgnomeprint-2.2 >= 2.4.0' but version of
>   libgnomeprint-2.2 is 2.3.1
>   configure: error: Library requirements (gtk+-2.0 >= 2.2.0
>   libgnomeprint-2.2 >= 2.4.0) not met; consider adjusting the
>   PKG_CONFIG_PATH environment variable if your libraries are in a
>   nonstandard prefix so pkg-config can find them.

You can try to force configure to look for libgnomeprint version 2.3.1 instead 
2.4.0. To do so you will have to obtain the code from the CVS repository, see
http://savannah.nongnu.org/projects/xlog/ , and change configure.in:

pkg_modules="gtk+-2.0 >= 2.2.0 libgnomeprint-2.2"


pkg_modules="gtk+-2.0 >= 2.2.0 libgnomeprint-2.2 >= 2.3.1"

After that you have to execute autogen.sh, which will automatically execute the
configure script. The bad news is that printing from xlog may become broken if 
really requires version 2.4.0 of libgnomeprint - the rest of the program should 

Alex, OZ9AEC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]