[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xlog-discussion] pkg-config error

From: w9ya
Subject: Re: [Xlog-discussion] pkg-config error
Date: Mon, 14 Jun 2004 13:01:51 -0500 (EST)

Hey John and the gang;

First off, I should tell you that while many folks will tell you that
compiling and installing a tarball on an rpm system is o.k...it really can
lead to problems sometime downstream of now.

But assuming you still want to try and install xlog on a Mandrake system.

1 - Mandrake 9.2 is kinda getting "long in the tooth" and you will
probably have to upgrade the package supplying libgnomeprint. If you need
help with how to do this I would suggest asking at the excellent irc
(internet relay chat) #mandrake channel at irc.freenode.net .

2 - You could consider upgrading your Mandrake 9.2 system to the more up
to date 10.0 OFFICIAL version. It will probably offer you a late enough
version of the files Xlog needs.

3 - Possibly someone has written an rpm spec file for this program ? If
so, and you intend to stay with a Linux distro that uses rpm, Mandrake has
an excellent tutorial page on making rpms. With an Xlog spec file and the
Xlog tarball you should be able to make your own Xlog rpm. The tutorial is
located here;


4 - There is a program that attempts to automatically write rpm spec files
from a program's "make-install" process. The name of this is
"checkinstall" and you can find out more by searching for this at
freshmeat.net . In all honesty though, I would imagine you would need to
at least be familiar with the content of the above mentioned Mandrake
rpm-making tutorial mentioned above.

Dunno if this helps you much, but vy 73 OM;


> Hello all,
> Trying to install xlog-0.9.6 on a Mandrake 9.2 machine and I get the
> following  message during configure:
>   checking for gtk+-2.0 >= 2.2.0 libgnomeprint-2.2 >= 2.4.0...
>   Requested 'libgnomeprint-2.2 >= 2.4.0' but version of
>   libgnomeprint-2.2 is 2.3.1
>   configure: error: Library requirements (gtk+-2.0 >= 2.2.0
>   libgnomeprint-2.2 >= 2.4.0) not met; consider adjusting the
>   PKG_CONFIG_PATH environment variable if your libraries are in a
> nonstandard prefix so pkg-config can find them.
> I then tried the following:
> # export PKG_CONFIG_PATH=/usr/lib/pkgconfig    (dir where my .rc files
> are) # ./configure
> Got the same error message...
> Any help will be greatly appreciated!
> tnx/73,
> John Pfeifer - KL0WN
> Kodiak, Alaska
> _______________________________________________
> Xlog-discussion mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/xlog-discussion

reply via email to

[Prev in Thread] Current Thread [Next in Thread]