[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: [slint] Re: I installed Slint 15.01 Again, Still NO sound

From: Didier Spaier
Subject: Re: Fwd: [slint] Re: I installed Slint 15.01 Again, Still NO sound
Date: Fri, 23 Dec 2022 19:51:54 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.6.1

Hi David,

No need to forward this message to the speechd-discuss list as there is no issue
with speech-dispatcher in you system (only possibly with your recently modified

More generally when you open a thread in a list, please post your answer in the
sames list and thread as else everybody, missing episodes the the show, will be
lost. In this case you have just been lucky that I follow this list too.

This not withstanding I will answer inline:

Le 23/12/2022 à 18:01, D.J.J. Ring, Jr. a écrit :
> PermissionError: [Errno 13] Permission denied: 'emacs.conf'
> I am running as regular user sthibault@debian.org 
> <mailto:sthibault@debian.org>
> I don't know why my user configuration "emacs.conf" is owned by root:root but 
> it is.
> ls -l /home/username/.config/speech-dispatcher/clients/emacs.conf 
> -rw-r--r-- 1 root root 116 Oct 30 18:29
> /home/username/.config/speech-dispatcher/clients/emacs.conf

Mots probably because you typed a command using 'su ' instead of "su -" or 

To fix that you could type:
su -
chown -R username: /home/username

I recommend that you do not use spd-conf at all.

It needs to be updated (planning to propose an update has been in my TODO list
since years, alas) further it is not necessary for yu as you  can just make the
generic settings in /etc/speech-dispatcher/speechd.conf and the specific ones
for Orca the Orca preferences GUI, unless I miss something.

> There is an error in the login-chooser script:
> login-chooser text
> Login will occur in text mode on next boot.
> If you need speech type one of these commands before rebooting:
> switch-on espeakup
> switch-on fenrir
> switch-on speechd-up
> To reboot immediatly press R then Enter, else just press Enter.
>> The word "immediately" is spelled incorrectly and "switch-on" in the script
> should be "speak-with".

Yes I forgot to update this script and made a typo (I should have written
immediately, not immediatly, thanks for the heads-up. But again this is the
wrong list for this information.

> Any idea how to correct those python errors?

As I wrote aboven fix the ownership of all files in /home/username


reply via email to

[Prev in Thread] Current Thread [Next in Thread]