[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fwd: [slint] Re: I installed Slint 15.01 Again, Still NO sound

From: D.J.J. Ring, Jr.
Subject: Fwd: [slint] Re: I installed Slint 15.01 Again, Still NO sound
Date: Fri, 23 Dec 2022 13:01:23 -0500

---------- Forwarded message ---------
From: D.J.J. Ring, Jr. <n1ea@arrl.net>
Date: Fri, Dec 23, 2022 at 12:35 PM
Subject: Re: [slint] Re: I installed Slint 15.01 Again, Still NO sound
To: <slint@freelists.org>

PROGRESS and Problems.

I'm going to post the problems separately.

I found a solution to the sound card problem.

I created a file /etc/modprobe.d/default and put in that file:
options snd_hda_intel index=1

Then I rebooted, but no screen reader in console.

But now "spd-say "Hello"" and "voxin-say "Hello" | aplay" both say "Hello" with the Voxin zoe-ml-embedded-high,en,US voice that I have installed.

I tried spd-conf to see if that was the problem.

I get these errors:

$ spd-conf

Speech Dispatcher configuration tool

Do you want to setup a completely new configuration? [yes] :
Do you want to create/setup a 'user' or 'system' configuration? [user] :
User configuration already exists.
Do you want to rewrite it with a new one? [no] :

Traceback (most recent call last):
  File "/usr/bin/spd-conf", line 26, in <module>
  File "/usr/lib64/python3.9/site-packages/speechd_config/config.py", line 834, in main
  File "/usr/lib64/python3.9/site-packages/speechd_config/config.py", line 746, in complete_config
  File "/usr/lib64/python3.9/site-packages/speechd_config/config.py", line 594, in create_user_configuration
  File "/usr/lib64/python3.9/site-packages/speechd_config/config.py", line 532, in remove_user_configuration
  File "/usr/lib64/python3.9/shutil.py", line 734, in rmtree
    _rmtree_safe_fd(fd, path, onerror)
  File "/usr/lib64/python3.9/shutil.py", line 667, in _rmtree_safe_fd
    _rmtree_safe_fd(dirfd, fullname, onerror)
  File "/usr/lib64/python3.9/shutil.py", line 690, in _rmtree_safe_fd
    onerror(os.unlink, fullname, sys.exc_info())
  File "/usr/lib64/python3.9/shutil.py", line 688, in _rmtree_safe_fd
    os.unlink(entry.name, dir_fd=topfd)
PermissionError: [Errno 13] Permission denied: 'emacs.conf'

I am running as regular user sthibault@debian.org

I don't know why my user configuration "emacs.conf" is owned by root:root but it is.
ls -l /home/username/.config/speech-dispatcher/clients/emacs.conf 
-rw-r--r-- 1 root root 116 Oct 30 18:29 /home/username/.config/speech-dispatcher/clients/emacs.conf

There is an error in the login-chooser script:

login-chooser text
Login will occur in text mode on next boot.

If you need speech type one of these commands before rebooting:
switch-on espeakup
switch-on fenrir
switch-on speechd-up
To reboot immediatly press R then Enter, else just press Enter.

The word "immediately" is spelled incorrectly and "switch-on" in the script should be "speak-with".

So progress is being made.

Any idea how to correct those python errors?



On Fri, Dec 23, 2022 at 4:39 AM Didier Spaier <didier@slint.fr> wrote:
Le 23/12/2022 à 03:57, D.J.J. Ring, Jr. a écrit :
> If I run.
> spd-say "hello" in console, I hear Zoe ML High Voxin voice - just as I'm
> supposed to but when I type letters I don't hear the screen reader.             

THis could be a different issue.
> voxin-say "hello" | aplay
> ALSA lib pcm_dmix.c:1032:(snd_pcm_dmix_open) unable to open slave
> aplay: main:831: audio open error: No such file or directory
> I get the same results in mate-terminal inside MATE and in console.
> I don't know what it means or how to fix it, but I believe that's the problem
> right there.

As I wrote in a previous email this means that the issue it with your Alsa
settings, not with speech-dispatcher or Voxin.

When you type this commands:
spd-say "hello"
alsa does not come into play, only pulseaudio as with your settings the audio
output method is pulseaudio, not alsa.

But if you type:
voxin-say "hello" | aplay
the output of vosin-say is trabnsferred to aplay as if yu had typed directly:
aplay "hello"
and aplay sends its output through alsa, which doesn't work, most probably
because of your not relevant alsa configuration.

Maybe the link I gave you is not that helpful, but try this;

But you could as well read the full article.

The Slint mailing list.
Archive: https://www.freelists.org/archive/slint
To subscribe or unsubscribe, email slint-request@freelists.org with the subject
'subscribe' or 'unsubscribe', then answer the email you will receive.
More: email slint-request@freelists.org with as subject 'help' or 'commands'.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]