[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] [Errno 13] Permission denied: '/home/username/.gvfs

From: Andreas Herrmann
Subject: [rdiff-backup-users] [Errno 13] Permission denied: '/home/username/.gvfs'
Date: Sun, 15 May 2011 00:45:57 +0200

Hello everyone,

I'm trying to create a backup of my system configuration using
rdiff-backup. The idea is to have a backup of `/etc' and a few dotfiles
in `$HOME' just in case I screw something up. Ideally this backup should
be performed by a cron job.

rdiff-backup is called as
    rdiff-backup --include-globbing-filelist file_list \
        / $HOME/.backup/local

where `file_list' looks like
    - /**~
    - /.*.swp
    - /**/.*.swp
    - /

The problem: As soon as I put any file inside home into `file_list' the
following error message appears and the backup fails.
    [Errno 13] Permission denied: '/home/username/.gvfs'

Adding `- /home/username/.gvfs' to the file list doesn't help.

Googling around revealed, that this is a known problem and has to do
with fuse [1,2]. [1] even says this issue would be solved in the cvs
version. I've tried 1.2.8, 1.3.3 and the latest cvs version. All produce
the same error message.
The exact error message is attached to the mail.

I had a look at the code myself, but it's not clear to me where to
handle this case. Non readable files should produce an error if they are
listed as source or destination. But, I do _not_ want to backup `.gvfs'
so it should _not_ produce an error...

A quick hack around this is given in [2]. But, it's definitely not an
option for a cron job.


[2] http://ubuntuforums.org/showthread.php?t=783935

Attachment: local_error
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]