[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] How to Enable virtio networking on windows host win8.

From: test comp
Subject: Re: [Qemu-discuss] How to Enable virtio networking on windows host win8.1
Date: Tue, 3 Nov 2015 17:17:25 -0800

Thanks For the Response,

yeah i have been through that doc before, but didn't work.

if it is a ubuntu host i don't have issue with networking.

But with windows 8 host, its not working as expected.

i tried bridging the tap network, and also user mode networking. But for some reason VM network is always internal.

It cannot connect to host or to external internet connection.

and most of the time i am getting this error while using tap network "qemu-system-i386.exe: -net tap,ifname=TAP: Device 'tap' could not be initialized"

trying all different combinations but nothing successful.
qemu-system-i386.exe -hda linux.img -boot c -vga std -net nic,model=virtio -net bridge,br=tapbr -m 1024 -net user,id=Ethernet,net=,dhcpstart= -redir tcp:5555::80 -redir tcp:5556::445

Again thanks for the inputs

On Mon, Nov 2, 2015 at 2:02 PM, <address@hidden> wrote:

On Mon, 2 Nov 2015, test comp wrote:

Hi All,
I am running qemu on windows 8 host and trying to get the network enabled on the linux guest with virtio drivers.
but not successful so far, i have also tried setting the static ip address and dns configuration on my linux guest. But
nothing works.

I am using 2.3.0 version Qemu and below is the command line i am executing.

qemu-system-x86_64.exe  -hda linux.img -boot c -vga std -net nic,model=virtio  -m 1024

qemu will create a network segment just for the emulated system. You need to connect that segment using e.g. the "-net user" option (NAT) or to connect it using a tap device.

For setting up the TAP device, I found this:

(I think setting up ICS is not what you'd want, I'd try to skip it and just breate the bridge. That's what I did on Linux.)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]