[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v3 04/16] vl: Rename *boot_devices to *boot_orde
From: |
Anthony Liguori |
Subject: |
Re: [Qemu-devel] [PATCH v3 04/16] vl: Rename *boot_devices to *boot_order, for consistency |
Date: |
Fri, 14 Jun 2013 08:38:32 -0500 |
User-agent: |
Notmuch/0.15.2+77~g661dcf8 (http://notmuchmail.org) Emacs/23.3.1 (x86_64-pc-linux-gnu) |
Markus Armbruster <address@hidden> writes:
> Signed-off-by: Markus Armbruster <address@hidden>
Reviewed-by: Anthony Liguori <address@hidden>
Regards,
Anthony Liguori
> ---
> include/hw/hw.h | 4 ++--
> vl.c | 16 ++++++++--------
> 2 files changed, 10 insertions(+), 10 deletions(-)
>
> diff --git a/include/hw/hw.h b/include/hw/hw.h
> index 1fb9afa..cc9f847 100644
> --- a/include/hw/hw.h
> +++ b/include/hw/hw.h
> @@ -44,9 +44,9 @@ void qemu_unregister_reset(QEMUResetHandler *func, void
> *opaque);
>
> /* handler to set the boot_device order for a specific type of QEMUMachine */
> /* return 0 if success */
> -typedef int QEMUBootSetHandler(void *opaque, const char *boot_devices);
> +typedef int QEMUBootSetHandler(void *opaque, const char *boot_order);
> void qemu_register_boot_set(QEMUBootSetHandler *func, void *opaque);
> -int qemu_boot_set(const char *boot_devices);
> +int qemu_boot_set(const char *boot_order);
>
> #ifdef NEED_CPU_H
> #if TARGET_LONG_BITS == 64
> diff --git a/vl.c b/vl.c
> index f51d8e8..17daedd 100644
> --- a/vl.c
> +++ b/vl.c
> @@ -1151,12 +1151,12 @@ void qemu_register_boot_set(QEMUBootSetHandler *func,
> void *opaque)
> boot_set_opaque = opaque;
> }
>
> -int qemu_boot_set(const char *boot_devices)
> +int qemu_boot_set(const char *boot_order)
> {
> if (!boot_set_handler) {
> return -EINVAL;
> }
> - return boot_set_handler(boot_set_opaque, boot_devices);
> + return boot_set_handler(boot_set_opaque, boot_order);
> }
>
> static void validate_bootdevices(const char *devices)
> @@ -1187,9 +1187,9 @@ static void validate_bootdevices(const char *devices)
> }
> }
>
> -static void restore_boot_devices(void *opaque)
> +static void restore_boot_order(void *opaque)
> {
> - char *standard_boot_devices = opaque;
> + char *normal_boot_order = opaque;
> static int first = 1;
>
> /* Restore boot order and remove ourselves after the first boot */
> @@ -1198,10 +1198,10 @@ static void restore_boot_devices(void *opaque)
> return;
> }
>
> - qemu_boot_set(standard_boot_devices);
> + qemu_boot_set(normal_boot_order);
>
> - qemu_unregister_reset(restore_boot_devices, standard_boot_devices);
> - g_free(standard_boot_devices);
> + qemu_unregister_reset(restore_boot_order, normal_boot_order);
> + g_free(normal_boot_order);
> }
>
> void add_boot_device_path(int32_t bootindex, DeviceState *dev,
> @@ -4090,7 +4090,7 @@ int main(int argc, char **argv, char **envp)
> validate_bootdevices(once);
> normal_boot_order = g_strdup(boot_order);
> boot_order = once;
> - qemu_register_reset(restore_boot_devices, normal_boot_order);
> + qemu_register_reset(restore_boot_order, normal_boot_order);
> }
>
> boot_menu = qemu_opt_get_bool(opts, "menu", boot_menu);
> --
> 1.7.11.7
- [Qemu-devel] [PATCH v3 00/16] -boot and -no-fd-bootchk fixes, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 04/16] vl: Rename *boot_devices to *boot_order, for consistency, Markus Armbruster, 2013/06/14
- Re: [Qemu-devel] [PATCH v3 04/16] vl: Rename *boot_devices to *boot_order, for consistency,
Anthony Liguori <=
- [Qemu-devel] [PATCH v3 02/16] qemu-option: check_params() is now unused, drop it, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 01/16] vl: Clean up parsing of -boot option argument, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 10/16] boot-order-test: Cover -boot once in ppc tests, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 05/16] pc: Make -no-fd-bootchk stick across boot order changes, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 07/16] qtest: Don't reset on qtest chardev connect, Markus Armbruster, 2013/06/14