[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v3 02/16] qemu-option: check_params() is now unu
From: |
Anthony Liguori |
Subject: |
Re: [Qemu-devel] [PATCH v3 02/16] qemu-option: check_params() is now unused, drop it |
Date: |
Fri, 14 Jun 2013 08:36:37 -0500 |
User-agent: |
Notmuch/0.15.2+77~g661dcf8 (http://notmuchmail.org) Emacs/23.3.1 (x86_64-pc-linux-gnu) |
Markus Armbruster <address@hidden> writes:
> Signed-off-by: Markus Armbruster <address@hidden>
Reviewed-by: Anthony Liguori <address@hidden>
Regards,
Anthony Liguori
> ---
> include/qemu/option.h | 2 --
> util/qemu-option.c | 30 ------------------------------
> 2 files changed, 32 deletions(-)
>
> diff --git a/include/qemu/option.h b/include/qemu/option.h
> index bdb6d21..a83c700 100644
> --- a/include/qemu/option.h
> +++ b/include/qemu/option.h
> @@ -55,8 +55,6 @@ int get_next_param_value(char *buf, int buf_size,
> const char *tag, const char **pstr);
> int get_param_value(char *buf, int buf_size,
> const char *tag, const char *str);
> -int check_params(char *buf, int buf_size,
> - const char * const *params, const char *str);
>
>
> /*
> diff --git a/util/qemu-option.c b/util/qemu-option.c
> index 8b74bf1..412c425 100644
> --- a/util/qemu-option.c
> +++ b/util/qemu-option.c
> @@ -123,36 +123,6 @@ int get_param_value(char *buf, int buf_size,
> return get_next_param_value(buf, buf_size, tag, &str);
> }
>
> -int check_params(char *buf, int buf_size,
> - const char * const *params, const char *str)
> -{
> - const char *p;
> - int i;
> -
> - p = str;
> - while (*p != '\0') {
> - p = get_opt_name(buf, buf_size, p, '=');
> - if (*p != '=') {
> - return -1;
> - }
> - p++;
> - for (i = 0; params[i] != NULL; i++) {
> - if (!strcmp(params[i], buf)) {
> - break;
> - }
> - }
> - if (params[i] == NULL) {
> - return -1;
> - }
> - p = get_opt_value(NULL, 0, p);
> - if (*p != ',') {
> - break;
> - }
> - p++;
> - }
> - return 0;
> -}
> -
> /*
> * Searches an option list for an option with the given name
> */
> --
> 1.7.11.7
- [Qemu-devel] [PATCH v3 00/16] -boot and -no-fd-bootchk fixes, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 04/16] vl: Rename *boot_devices to *boot_order, for consistency, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 02/16] qemu-option: check_params() is now unused, drop it, Markus Armbruster, 2013/06/14
- Re: [Qemu-devel] [PATCH v3 02/16] qemu-option: check_params() is now unused, drop it,
Anthony Liguori <=
- [Qemu-devel] [PATCH v3 01/16] vl: Clean up parsing of -boot option argument, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 10/16] boot-order-test: Cover -boot once in ppc tests, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 05/16] pc: Make -no-fd-bootchk stick across boot order changes, Markus Armbruster, 2013/06/14
- [Qemu-devel] [PATCH v3 07/16] qtest: Don't reset on qtest chardev connect, Markus Armbruster, 2013/06/14