[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Re: winblows 2k on OSX?

From: René Korthaus
Subject: Re: [Qemu-devel] Re: winblows 2k on OSX?
Date: Thu, 22 Jul 2004 21:44:09 +0200

Am 22.07.2004 um 21:13 schrieb André Braga:

I tried running a CD straight from the block device node and it failed
*every time*, irregardless of the permissions or the user I tried
running QEMU from. So I'd say you can't do it, as simple as that (but
I haven't tried booting straight as the root user on OS X; that might
work but I seriously doubt it). Images always work, though.

Someone just said some days ago, that you have to unmount the disk first, so i tried but it failed. Now i tried sudo umount /dev/disk1s1s2 and it worked. It still appears in the finder window, but clicking on it exits in an error (original not found...). Now starting Qemu with -cdrom /dev/disk1 lets the cdrom drive start running (can hear it), it lasts 3/4 seconds and qemu starts. boot failure 0003. But i guess thats because i still havent found bootable disk. Please try yourself and tell me.



On Thu, 22 Jul 2004 21:09:08 +0200, René Korthaus <address@hidden> wrote:

Am 22.07.2004 um 20:39 schrieb Jason:

well, I was using that actually, but I just wanted to doublecheck..
I created a blank image file, and when I run that, I get

mybox:~/qemu_images root# /opt/local/bin/qemu win2k.img -cdrom
/dev/disk1s0 -boot d
/dev/disk1s0: Device busy
qemu: could not open hard disk image '/dev/disk1s0
mybox:~/qemu_images root#

thats after I ejected, re-inserted the win2k cdrom. Im not sure why
its busy,
but Im sure that /dev/disk1s0 is the CDROM on OSX.

I tried booting qnx 6.2.1 with -cdrom /dev/disk1 on ibook (got device
name out of system profiler) and cdrom mounted in finder. Could not
access cd0 from qnx, but unmounting the cdrom drive by the finder did
not eject it also!! So i guess it was used by qnx now. All of your
variants with -cdrom /dev/disk xy resulted in "could not open hard disk image....", but booting with /dev/disk1 worked til "could not read boot
disk" by bios-screen. I cannot try this with a bootable cd, because i
justed moved and cannot find my w98 and w2k cds. But i will have a look
and post....


On Thu, Jul 22, 2004 at 11:24:08AM -0700, Ben Pfaff wrote:
Jason <address@hidden> writes:

a friend just turned me onto the qemu and I have it installed on my
running OSX. Ive run the sample linux and dos images, but how would
I go about
installing win2k from CD?

Create a disk image, e.g. w2k.img, then boot Windows 2k from the
CD, e.g.:
        qemu w2k.img -cdrom /dev/cdrom -boot d
I don't know what the name of the OS X CD-ROM device is; the
above assumes /dev/cdrom.

After install finishes, you should be able to boot directly from
the disk image, e.g.
        qemu w2k.img

"Physics is not a religion. If it were, we'd have a much easier time
raising money"
-Leon Lenderman

Qemu-devel mailing list

Qemu on Mac OS X Tutorial
Please add patches and screenshots

reply via email to

[Prev in Thread] Current Thread [Next in Thread]