[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Pan-users] segmentation fault trying to use Pan 0.146: "strftime_l.c no

From: Julien Michielsen
Subject: [Pan-users] segmentation fault trying to use Pan 0.146: "strftime_l.c no such file or directory"
Date: Sun, 01 Dec 2019 14:07:05 +0100
User-agent: XS4ALL Webmail

I compiled and installed the latest Pan because I continued
to get a segmentation fault with the "standard Pan 0.144"
that came with Ubuntu 18.0.4.  No help: I still get the same
error message, with the same announcement.  I ran the program
under gdb and got the following output:

Starting program: /usr/local/bin/pan
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[New Thread 0x7fffec030700 (LWP 11360)]
[New Thread 0x7fffeb82f700 (LWP 11361)]
[New Thread 0x7fffeb02e700 (LWP 11362)]
[New Thread 0x7fffea82d700 (LWP 11363)]
[New Thread 0x7fffe93b9700 (LWP 11364)]
[New Thread 0x7fffe8bb8700 (LWP 11365)]
[New Thread 0x7fffd3fff700 (LWP 11366)]
[New Thread 0x7fffd37fe700 (LWP 11367)]
[Thread 0x7fffd37fe700 (LWP 11367) exited]
[Thread 0x7fffd3fff700 (LWP 11366) exited]

Thread 1 "pan" received signal SIGSEGV, Segmentation fault.
__strftime_internal (s=0x7fffffffbb30 "@\033\271\365\377\177", maxsize=100, format=0x0, tp=0x7fffffffbaf0, tzset_called=tzset_called@entry=0x7fffffffba97, loc=0x7ffff5b95560 <_nl_global_locale>) at strftime_l.c:560
560     strftime_l.c: No such file or directory.

I also asked for a backtrace, and got the output from it,
but don't think this is usefull for this list. If this output
would be welcome to someone, I'll be happy to supply it.
I looked if the file strftime_l.c resides on my computer, but
it doesn't.
Does anyone have a hint how to get this running?
Julien Michielsen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]