[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Pan-users] segmentation fault trying to use Pan 0.146: "strftime_l.

From: Per Hedeland
Subject: Re: [Pan-users] segmentation fault trying to use Pan 0.146: "strftime_l.c no such file or directory"
Date: Sun, 1 Dec 2019 14:41:25 +0100
User-agent: Mozilla/5.0 (X11; FreeBSD amd64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1

On 2019-12-01 14:07, Julien Michielsen wrote:
I compiled and installed the latest Pan because I continued
to get a segmentation fault with the "standard Pan 0.144"
that came with Ubuntu 18.0.4.  No help: I still get the same
error message, with the same announcement.  I ran the program
under gdb and got the following output:

Starting program: /usr/local/bin/pan
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[New Thread 0x7fffec030700 (LWP 11360)]
[New Thread 0x7fffeb82f700 (LWP 11361)]
[New Thread 0x7fffeb02e700 (LWP 11362)]
[New Thread 0x7fffea82d700 (LWP 11363)]
[New Thread 0x7fffe93b9700 (LWP 11364)]
[New Thread 0x7fffe8bb8700 (LWP 11365)]
[New Thread 0x7fffd3fff700 (LWP 11366)]
[New Thread 0x7fffd37fe700 (LWP 11367)]
[Thread 0x7fffd37fe700 (LWP 11367) exited]
[Thread 0x7fffd3fff700 (LWP 11366) exited]

Thread 1 "pan" received signal SIGSEGV, Segmentation fault.
__strftime_internal (s=0x7fffffffbb30 "@\033\271\365\377\177", maxsize=100, 
format=0x0, tp=0x7fffffffbaf0,
     tzset_called=tzset_called@entry=0x7fffffffba97, loc=0x7ffff5b95560 
<_nl_global_locale>) at strftime_l.c:560
560    strftime_l.c: No such file or directory.

I also asked for a backtrace, and got the output from it,
but don't think this is usefull for this list.

I don't know why it wouldn't be - I don't think there is a dedicated
"developer" list.

If this output
would be welcome to someone, I'll be happy to supply it.

Please do. The crash is likely caused by the 'format=0x0' argument, it
should be (a pointer to) a format string for strftime_l(), see the
strftime(3) man page. The full backtrace might explain how this came

I looked if the file strftime_l.c resides on my computer, but
it doesn't.

This isn't the problem, it's just gdb that tries to print out the
relevant source code lines, and reports that it can't since you don't
have the source (in a place where gdb can find it). I googled
strftime_l.c, and the first hit was a glibc version at - and it
seems it is even the right version (probably doesn't change much),
line 560 is:

  for (f = format; *f != '\0'; ++f)

This will indeed cause a segfault due to the *f dereference if format
is 0/NULL.

Does anyone have a hint how to get this running?

Not me - FWIW, Pan 0.145 works fine for me on FreeBSD. It may be
something specific to your environment. Does it crash immediately on
startup, i.e. doesn't even display a window? If not, how far does it

--Per Hedeland

reply via email to

[Prev in Thread] Current Thread [Next in Thread]