[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU make 4.2 (and 4.2.1) failing due to length of command-line

From: Paul Smith
Subject: Re: GNU make 4.2 (and 4.2.1) failing due to length of command-line
Date: Wed, 22 Jun 2016 15:21:35 -0400

On Wed, 2016-06-22 at 18:48 +0000, Adrian Muresan wrote:
> I ran using GNU make 3.81 from two different sources:
> once using the binary form sourceforge 
> And 
> once using the binary from QNX. 
> QNX gave no error and SourceForge gave an error (the same error as
> 4.2, 4.2.1 I built and the 4.0+ binary version Eli told me to get
> from SourceForge). 
> Doesn't this prove there's a bug? As Eli said, QNX obviously patched
> something since everything else, even the shell used, was the same.

It proves that the QNX version of GNU make did something to work around
the deficiencies of the shell.  That's not necessarily a bug in GNU
make: it's not clear that adding that workaround, whatever it was, as a
permanent solution into GNU make is the right thing to do.

A better answer would be to fix the tool (the shell) so that it didn't
have this deficiency so that no workaround was required.

In any event, there's nothing else to be done until you try a 4.2.1
build configured with the BATCH_MODE_ONLY_SHELL setting and see if that
works, and report back to us.

If it does, then the problem is solved.

If it doesn't, then you'll need to contact QNX and find out what
changes they made to GNU make.  Once we know that we can decide what
the next step might be.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]