[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU make 4.2 (and 4.2.1) failing due to length of command-line

From: Eli Zaretskii
Subject: Re: GNU make 4.2 (and 4.2.1) failing due to length of command-line
Date: Wed, 22 Jun 2016 20:22:30 +0300

> From: Adrian Muresan <address@hidden>
> CC: "address@hidden" <address@hidden>
> Date: Wed, 22 Jun 2016 17:01:22 +0000
> I downloaded 
> I ran the command
> C:\Users\mureadr\Desktop\A\HMI_FORGF\bld\armle-v7\release\fordhmi>"C:\Users\mureadr\Downloads\make-4.2-without-guile-w32-bin\bin\make.exe"
>  deploy_marketProperties --debug=vjm --print-data-base > 42-SForge.err 2>&1
> And I still got the same error (see attachment).
> This time, I kept the entire output so you can reproduce it exactly. 

Thanks.  Indeed, I see the command truncated at 16384 bytes,
i.e. exactly 16KB.  This seems to be the limitation of sh.exe itself,
because if I replace the 1st "echo" on the command line with
"echo.exe", and remove all the && and the quotes (which force Make to
invoke the command through the shell), then I see the full untruncated
command line in the output.  Which means invoking echo.exe directly
with such long command lines does work, and the truncation is not
Make's fault.

So my guess is that your make 3.81 used a disk file to run the shell
command as a script, whereas the default build of Make 4.2 invokes the
shell directly.  You could try rebuilding Make 4.2 with
BATCH_MODE_ONLY_SHELL defined, see the end of the file config.h.  Or
maybe you could find a better port of Bash that doesn't suffer from
this limitation.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]