[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU make 4.2 (and 4.2.1) failing due to length of command-line

From: Adrian Muresan
Subject: Re: GNU make 4.2 (and 4.2.1) failing due to length of command-line
Date: Wed, 22 Jun 2016 18:48:35 +0000

I ran using GNU make 3.81 from two different sources:

once using the binary form sourceforge 
once using the binary from QNX. 

QNX gave no error and SourceForge gave an error (the same error as 4.2, 4.2.1 I 
built and the 4.0+ binary version Eli told me to get from SourceForge). 

Doesn't this prove there's a bug? As Eli said, QNX obviously patched something 
since everything else, even the shell used, was the same. 

Sent from my iPhone

> On Jun 22, 2016, at 2:38 PM, Paul Smith <address@hidden> wrote:
> As Eli's tests, and even your output, show, GNU make is invoking the
> command with the complete command line, so there's no issue with GNU
> make.  It's the command we're invoking which is somehow truncating the
> command line, not GNU make.
> It's possible that the already-suggested BATCH_MODE_ONLY_SHELL setting
> will help, but this is a workaround for commands which can't accept
> very large command lines.
> So based on the information we have so far there's no bug in GNU make
> and no need to submit a bug report.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]