[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Configuring Linphone to use Opus on BeagleBone

From: Guillaume Bienkowski
Subject: Re: [Linphone-developers] Configuring Linphone to use Opus on BeagleBone Black
Date: Thu, 30 Apr 2015 15:50:38 +0200

Hey Matt,

I suspect Opus doesn’t set the version in its opus.pc file. Could you check that ? It should exist in /usr/lib/pkgconfig/opus.pc
On my Ubuntu here, there is no pkgconfig file, so that might explain the problem.

You could try to set the _CFLAGS and _LIBS by hand, yes, and see how it goes.

Otherwise, you could try compiling the opus version that we use in our mobile apps: git// at commit da97db1ca1f92592af3534c9a2596da0e9a009ca
It embarks a .pc file which will be picked up by pkgconfig.

Once you install this opus (in a prefix, say $PREFIX) you should configure linphone with:

PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig ./configure --enable-fixed-point --enable-opus CFLAGS="-march=armv7-a -mtune=cortex-a8 -O3 »

Guillaume Bienkowski

Le 30 avr. 2015 à 14:49, Matt Murphy <address@hidden> a écrit :

Hi Guillaume,

Thanks a lot for the quick reply. I pulled up the config.log file as requested. It seems like there is a problem determining the version of Opus I have installed, which seems a little odd.

Here is the relevant snippet:

configure:21429: checking for OPUS
configure:21436: $PKG_CONFIG --exists --print-errors "opus >= 0.9.0"
Requested 'opus >= 0.9.0' but version of Opus is unknown
You may find new versions of Opus at
configure:21439: $? = 1
configure:21453: $PKG_CONFIG --exists --print-errors "opus >= 0.9.0"
Requested 'opus >= 0.9.0' but version of Opus is unknown
You may find new versions of Opus at
configure:21456: $? = 1
configure:21470: result: no
Requested 'opus >= 0.9.0' but version of Opus is unknown
You may find new versions of Opus at 
I also have these Opus references in the config.log file:




I guess I would expect something like:

OPUS_LIBS='-L/usr/local/lib -lopus'
Do I need to manually add the OPUS_CFLAGS and OPUS_LIBS?

I really appreciate the help, thank you so much!


On Thursday, April 30, 2015 5:42 AM, Guillaume Bienkowski <address@hidden> wrote:

Hey Matt,

Can you take a look into the mediastreamer2/config.log file to see why mediastreamer2 doesn’t see the opus codec?

Guillaume Bienkowski

Le 29 avr. 2015 à 21:16, Matt Murphy <address@hidden> a écrit :

Greetings everyone,

I am attempting to build Linphone on my BeagleBone black (BBB) and I want to do some tests with the Opus codec installed. I have successfully put Linphone on another BBB and it works flawlessly using speex. My issue is that I can't ever get opus recognized when I run ./configure.

I always see the following:
checking for SPANDSP... no
checking for LIBUPNP... yes
checking for OPUS... no
checking for FFMPEG... yes
checking for SWSCALE... yes

I have tried installing opus-1.1 from source and ldconfig seems to indicate that all is well, because I see: (libc6,hard-float) => /usr/local/lib/ (libc6,hard-float) => /usr/lib/ (libc6,hard-float) => /usr/local/lib/ (libc6,hard-float) => /usr/lib/

I have also tried using apt-get install libopus-dev opus-tools, but still no joy.

I can successfully use opusenc to encode a wav file, so I get some satisfaction from that.

But if I build linphone, I never see opus show up as enabled or disabled when I do a codec list command.

If it matters, I am doing configure like this:
./configure --enable-fixed-point --enable-opus CFLAGS="-march=armv7-a -mtune=cortex-a8 -O3"

Any thoughts on what I can try to get this working?

Thanks for your help!

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]