[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Configuring Linphone to use Opus on BeagleBone

From: Guillaume Bienkowski
Subject: Re: [Linphone-developers] Configuring Linphone to use Opus on BeagleBone Black
Date: Thu, 30 Apr 2015 11:41:48 +0200

Hey Matt,

Can you take a look into the mediastreamer2/config.log file to see why mediastreamer2 doesn’t see the opus codec?

Guillaume Bienkowski

Le 29 avr. 2015 à 21:16, Matt Murphy <address@hidden> a écrit :

Greetings everyone,

I am attempting to build Linphone on my BeagleBone black (BBB) and I want to do some tests with the Opus codec installed. I have successfully put Linphone on another BBB and it works flawlessly using speex. My issue is that I can't ever get opus recognized when I run ./configure.

I always see the following:
checking for SPANDSP... no
checking for LIBUPNP... yes
checking for OPUS... no
checking for FFMPEG... yes
checking for SWSCALE... yes

I have tried installing opus-1.1 from source and ldconfig seems to indicate that all is well, because I see: (libc6,hard-float) => /usr/local/lib/ (libc6,hard-float) => /usr/lib/ (libc6,hard-float) => /usr/local/lib/ (libc6,hard-float) => /usr/lib/

I have also tried using apt-get install libopus-dev opus-tools, but still no joy.

I can successfully use opusenc to encode a wav file, so I get some satisfaction from that.

But if I build linphone, I never see opus show up as enabled or disabled when I do a codec list command.

If it matters, I am doing configure like this:
./configure --enable-fixed-point --enable-opus CFLAGS="-march=armv7-a -mtune=cortex-a8 -O3"

Any thoughts on what I can try to get this working?

Thanks for your help!

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]