[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] git clone errors while getting linphone source

From: Peter Hillier
Subject: Re: [Linphone-developers] git clone errors while getting linphone source
Date: Sun, 23 Mar 2014 20:38:03 -0700 (PDT)

Thanks for the reply and instructions.

I actually ran git clone and suspended the task after it fetched the core git files, then edited the .gitmodules similar to your instructions,  and then resumed the task.

+1 for providing the correct git commands - this will help the next time I run into this sort of issue. 

I raised a ticket to the opus dev group to notify them of the issue.


On Sunday, March 23, 2014 10:52:44 PM, powerqian <address@hidden> wrote:
Same issue here. I changed the git link of opus to

You need to

1. Edit the .gitmodules file.
2. Find [submodule "submodules/externals/opus"]
3. Change that section to
[submodule "submodules/externals/opus"]
    path = submodules/externals/opus
    url = "" shape="rect" href="" target="_blank">
4. run command: git submodule deinit -f .
5. run command: git submodule update --init --recursive

When cloning the opus submodule, there will be no progress. Please be
patient and wait. It worked for me.

View this message in context:
Sent from the linphone-developers mailing list archive at

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]