[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Help compiling

From: Jerry Bin
Subject: Re: [Linphone-developers] Help compiling
Date: Sat, 14 Jul 2012 19:57:59 +0300

Thanks for the advice,
I have tried this now,
and i simply get other errors..
Is it possible to upload to the repository also the "linphone-sdk" and spare the need of the exhausting compliing..
i've spent almost 3 days just trying to complie the sdk, following every tutorial i've found on the net..
Maybe someone has a VMware image or any other kind of image that already has this installed,
I am losing fate that it is actually possible to compile this..

On Sat, Jul 14, 2012 at 5:29 PM, Ramon Poca <address@hidden> wrote:
Might be something obvious, have you cloned the repository with --recursive? Also, if you tried to compile without a sane toolchain, I'd recommend to just remove and clone again the whole repository. It happened to me that some failed builds left the tree unusable, and not even doing a "sudo make veryclean" fixed that.

On Sat, Jul 14, 2012 at 2:48 PM, Jerry Bin <address@hidden> wrote:
So i've managed to move forward a bit in compiling the sdk,
and i sent the "sudo make all" command inside the build folder (as written)
and now i get this error:
cd /Users/linphone-iphone/submodules/build/..//linphone && ./
/bin/sh: ./ No such file or directory
make[1]: *** [/Users/linphone-iphone/submodules/build/..//linphone/configure] Error 127
make: *** [build] Error 2
I've tried both with nawk installed and uninstalled (which did help..)..
did someone encounter this problem?
On Sat, Jul 14, 2012 at 3:31 PM, Jerry Bin <address@hidden> wrote:
That worked!

On Sat, Jul 14, 2012 at 12:43 PM, Yann Diorcet <address@hidden> wrote:

Did you try to uninstall nawk? sudo port uninstall nawk
(the README say to install nawk but i haven't succeed to install all the require packages with it)

2012/7/14 Jerry Bin <address@hidden>
I've tried compiling Linphone for IPhone in the last week,
and i have really tried everything and read everything,
but i don't manage to install the macports doxygen port, which is written as a requirment..
everytime i do
"sudo ports install doxygen"
it writes that it is failing to install "graphviz"..
so i've tried installling graphviz with the pkg installer, but macports doesn't recongnize it, so it tries installing again and failes..
please help me...

Linphone-developers mailing list

Linphone-developers mailing list

Linphone-developers mailing list

Ramon Poca
Numancia 73, 5º-A. 08029 Barcelona
Telèfon directe: +34 93 184 52 84
Centraleta: +34 93 184 52 80
Fax: +34 93 419 69 31

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]