[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Reading the hardware clock

From: Bruno Dantas
Subject: Re: [Libreboot] Reading the hardware clock
Date: Fri, 29 Jan 2016 08:55:20 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.5.0

Thanks, Daniel.

I had tried:
$ sudo ntpd -qg && sudo hwclock --systohc

Just to exclude the possibility that the hwclock couldn't be read because it 
didn't have a time or the time was way off.

Now I understand the issue: The hwclock has the correct time, but it can't be 
read during boot so the system clock has no idea what time it is after boot.

I'm on Parabola (Arch fork), so there's no /sbin--only /usr/bin. Here are the 
pastes you requested:

address@hidden ~ $ date
Wed Dec 31 19:01:42 EST 1969

address@hidden ~ $ sudo /usr/bin/hwclock -r
hwclock: ioctl(RTC_RD_TIME) to /dev/rtc to read the time failed: Invalid 

address@hidden ~ $ sudo /usr/bin/hwclock --directisa -r
Fri 29 Jan 2016 08:40:06 AM EST  .048662 seconds

So, indeed, the hwclock CAN be read with the --directisa argument.

I retried the generic instructions here 
( and made sure both 
/usr/bin/hwclock.dist AND the /usr/bin/hwclock script were executable. Still no 

Arch linux (and therefore also Parabola) uses systemd, so I can't stick the 
--directisa in an init script (alas). What exactly is trying to read the 
hwclock--is it the kernel itself or systemd? Whichever one it is, it is 
obviously not doing it via a call to the hwclock command, otherwise the 
"generic instructions" would have worked.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]