[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Reading the hardware clock

From: Bruno Dantas
Subject: Re: [Libreboot] Reading the hardware clock
Date: Thu, 28 Jan 2016 17:09:47 -0500

I am having the same problem. I'm on a Thinkpad T400 with Libreboot and 
Parabola GNU/Linux-libre. After upgrading to linux-libre 4.3.4, now during 
every boot I see "rtc_cmos unable to read the hardware clock". When boot 
finishes and I'm at my desktop, I see that the time is 7 p.m. on December 31, 

In a terminal I ran:
$ sudo ntpd -qg
$ sudo hwclock --systohc

I needed to run the second command twice because the first time it gave an 
error (something about an invalid argument), but second time it works. Time and 
date are now correct but only until I reboot, when I get the boot-time error 
and it's 1969 again.

I tried the generic instructions here 
( and rebooted, but no 
luck. Still have the boot-time error and find myself in 1969. I'm not sure 
where to go from here.

My workaround for the time being is to use an older kernel (I downloaded 
linux-lts-4.1.9-2 and linux-lts-headers-4.1.9-2 from and installed with pacman 
-U), which is working fine.

I'd love to go back to the linux-libre kernel. Hopefully either linux-libre or 
libreboot can be fixed. I'd be very afraid to mess with libreboot itself, 
however (I probably wouldn't even have the necessary tools).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]