[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] OpenBSD with libreboot on the X200

From: Oriol Demaria
Subject: Re: [Libreboot] OpenBSD with libreboot on the X200
Date: Sun, 10 May 2015 15:22:01 +0100
User-agent: Roundcube Webmail/1.1.0

It keeps having the same problem, I don't see any output in the screen, I get to the biosboot and last line is the one that I think is seeding the random number generator. I can't log into any terminal, although it seems that it keeps going on for the hardrive led, and the block num led, but you just can't see anything on the screen. I will try to debug this through serial port or maybe I could ssh into the box from another one.


On , Oriol Demaria wrote:
Yes I thought about recompiling the kernel, and booting with a custom
kernel. With SeaBIOS I get to type the disk encryption password, but
that's it. It's worth a try this, because apart from PXE the rest I
have tried. I actually seems to boot till certain point but you can't
see anything or switch to any tty. I'm getting a docking station, that
I think it has a serial port, then I will be able to see what is going
on, through the serial cable.

So to boot OpenBSD I have to use SeaBIOS to boot from the first
partition where I have another grub, as for some reason I can't
chainload directly from libreboots grub, and then start it. I
installed OpenBSD with the harddrive in other box to try to isolate
the problem. I have also used grub to load bsd.rd without success. I
have tried several ways. But usually I just boot from a pendrive with
grub calling bsd.rd from the loopback interface of an iso file (this
works perfectly in for any box).

Thank you very much for your advice.


On , L.R. D.S. wrote:
So you chainload SeaBIOS, and try to boot the bsd.rd and it don't show
nothing? Your conclusion
is that it's because don't have framebuffer?
I don't know exactly how is the boot process on OpenBSD (although I
use it daily), but I don't
think that it require framebuffer to boot.
What do you are using to boot? A plain snapshot of install57.iso
burned on some CD-ROM?
You tried the pxeboot?
If nothing works, you could try compile with aperture driver disabled:
And, reduce the secure level:

If not working, try the openbsd-misc and request some help (please,
send some dmegs and dmidecode/biosdecode logs).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]