[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] libz?

From: email builder
Subject: [Jailkit-users] libz?
Date: Mon, 9 Jan 2012 18:57:49 -0800 (PST)


I've started to get these errors from jk_check in my cron

ERROR: /jail/usr/lib/libz.so.1 and /usr/lib/libz.so.1 have a different size!
ERROR: /jail/usr/lib/libz.so.1.2.3 and /usr/lib/libz.so.1.2.3 have a different 

But what was hard to understand was if I ran jk_update
it wouldn't do anything or notice any problems.  I also
tried to re-run jk_init, but that didn't do anything either.

I just went ahead and deleted all the libz.so.* that I
could find in /jail/usr/lib AND /jail/lib.  I also ran jk_init
and jk_update after that and it didn't do anything as
if libz shouldn't have been there in the first place (so
why/how would it have been there?)

In the process, I realized I didn't provide zip and unzip
to jailed users, so I added /usr/bin/zip and /usr/bin/unzip
to [basicshell]'s "executables" line in /etc/jailkit/jk_init.ini
and re-ran jk_init and that worked great.

But I'm wondering why libz was in my jail in the first
place and why it wouldn't update or get removed if it
shouldn't have been there?  What does it provide?
Should I somehow add it back?

Any tips or help?

Thank you!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]