[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] libz?

From: email builder
Subject: Re: [Jailkit-users] libz?
Date: Tue, 17 Jan 2012 12:10:33 -0800 (PST)

>>  I've started to get these errors from jk_check in my cron

>>  notifications:
>>  ERROR: /jail/usr/lib/libz.so.1 and /usr/lib/libz.so.1 have a different 
> size!
>>  ERROR: /jail/usr/lib/libz.so.1.2.3 and /usr/lib/libz.so.1.2.3 have a 
> different size!
>>  But what was hard to understand was if I ran jk_update
>>  it wouldn't do anything or notice any problems.  I also
>>  tried to re-run jk_init, but that didn't do anything either.
> if you ran jk_update -v (verbose) would that tell you that libz was checked 
> for 
> updates? (probably too late to test now). This could be a bug in jailkit, so 
> if 
> you could help to find what was going on..

I guess it's too late.  Running with -v doesn't provide anything interesting.
I'd be happy to try to help in some way like copying libz back into the
jail or something but that probably won't recreate the same situation.  Is
there anything else I could do to help figure this out?

>>  I just went ahead and deleted all the libz.so.* that I
>>  could find in /jail/usr/lib AND /jail/lib.  I also ran jk_init
>>  and jk_update after that and it didn't do anything as
>>  if libz shouldn't have been there in the first place (so
>>  why/how would it have been there?)
> possibly it was used by another binary that is no longer in your jail?

Well, I haven't changed the jail configuration for a few years,
so whatever binaries that have changed in the jail are only
those that change in the normal course of O/S updates.

>>  But I'm wondering why libz was in my jail in the first
>>  place and why it wouldn't update or get removed if it
>>  shouldn't have been there?  What does it provide?
>>  Should I somehow add it back?
> possibly you have a binary in your jail right now that does not function 
> anymore. The other possibility is that you previously had a binary in your 
> jail 
> that needed libz but the binary is not there anymore or it doesn't need libz 
> anymore.

I'm not sure what tools libz provides or what binaries use
libz.  Do you know?  jk_update or jk_check both do not
currently complain about missing libz or try to add it.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]