[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] libz?

From: Olivier Sessink
Subject: Re: [Jailkit-users] libz?
Date: Tue, 17 Jan 2012 08:42:40 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20111124 Thunderbird/8.0

On 01/10/2012 03:57 AM, email builder wrote:

I've started to get these errors from jk_check in my cron

ERROR: /jail/usr/lib/libz.so.1 and /usr/lib/libz.so.1 have a different size!
ERROR: /jail/usr/lib/libz.so.1.2.3 and /usr/lib/libz.so.1.2.3 have a different 

But what was hard to understand was if I ran jk_update
it wouldn't do anything or notice any problems.  I also
tried to re-run jk_init, but that didn't do anything either.

if you ran jk_update -v (verbose) would that tell you that libz was checked for updates? (probably too late to test now). This could be a bug in jailkit, so if you could help to find what was going on..

I just went ahead and deleted all the libz.so.* that I
could find in /jail/usr/lib AND /jail/lib.  I also ran jk_init
and jk_update after that and it didn't do anything as
if libz shouldn't have been there in the first place (so
why/how would it have been there?)

possibly it was used by another binary that is no longer in your jail?

But I'm wondering why libz was in my jail in the first
place and why it wouldn't update or get removed if it
shouldn't have been there?  What does it provide?
Should I somehow add it back?

possibly you have a binary in your jail right now that does not function anymore. The other possibility is that you previously had a binary in your jail that needed libz but the binary is not there anymore or it doesn't need libz anymore.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]