[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub freezes when it touches large initrd

From: JZB
Subject: Re: Grub freezes when it touches large initrd
Date: Thu, 3 Jun 2021 21:34:35 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.3.2

Just a side-note, when I tried to use an initramfs (not quite the same
as initrd) embedded into my kernel binary (as initramfs's are), when the
unexpanded size exceeded 512 MB, the system would hang.

I have successfully run initramfs's that expand to less than 512 MB, but
never greater.  I tried looking for an "official" answer on a 512 MB
limit for initrd/initramfs, but never could find one, thus putting my
dreams of a full server distro. on a ramdisk on hold for the moment.

I guess all I'm saying is maybe it ain't a grub thing...try it with
syslinux for comparison.


On 6/3/21 5:33 PM, Pascal-liste wrote:
> Le 03/06/2021 à 07:42, Andrei Borzenkov a écrit :
>> On 02.06.2021 18:02, wrote:
>>> I am trying to boot the system with an initrd that is 406MB (gzip
>>> compressed) in size on x86_64 system with 256G RAM via UEFI. I use
>>> bootloader binaries (GRUBX64.efi and BOOTX64.efi) from Ubuntu Bionic.
>>> Kernel is also from the same distro.
>>> When I get to Grub prompt I can normally load the kernel with:
>>> Grub>linuxefi /vmlinuz
>>> Howewer when I try to load initrd the Grub crashes and what follows
>>> is "red screen of death" with:
>>> X64 Exception Type 0x03 - Breakpoint Exception
>>> ...
>>> CALL ImageBase        ImageName+Offset
>>> 00h  0000000000000000 No Image Information
>>> CALL ImageBase        ImageName+Offset
>>> ...
>>> The same happens even if I just try to do "ls -la" on the directory
>>> that contains that initrd.
>> In this case it is unlikely related to size. Rather there is something
>> with this specific file inode that makes grub crash.
> How then do you explain this :
>>> I have tried with few initrd images ranging between 300MB and 400MB,
>>> but result was the same
>>> On the other hand everything works well when I boot with an initrd
>>> that is around 70MB big.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]