[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub freezes when it touches large initrd

From: Andrei Borzenkov
Subject: Re: Grub freezes when it touches large initrd
Date: Thu, 3 Jun 2021 08:42:31 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.8.1

On 02.06.2021 18:02, wrote:
> Hello everybody,
> I am fighting with one issue since two months and still could not get to the 
> bottom of it.
> Namely I am trying to boot the system with an initrd that is 406MB (gzip 
> compressed) in size on x86_64 system with 256G RAM via UEFI. I use bootloader 
> binaries (GRUBX64.efi and BOOTX64.efi) from Ubuntu Bionic. Kernel is also 
> from the same distro.
> When I get to Grub prompt I can normally load the kernel with:
> Grub>linuxefi /vmlinuz
> Howewer when I try to load initrd the Grub crashes and what follows is "red 
> screen of death" with:
> X64 Exception Type 0x03 - Breakpoint Exception
> ...
> CALL ImageBase        ImageName+Offset
> 00h  0000000000000000 No Image Information
> CALL ImageBase        ImageName+Offset
> ...
> The same happens even if I just try to do "ls -la" on the directory that 
> contains that initrd.

In this case it is unlikely related to size. Rather there is something
with this specific file inode that makes grub crash. Which filesystem is
it on?

> If I do "ls" only it does not happen.

Well, it does not attempt to access file properties and just lists
directory content.

> I assume in former case it tries to calculate the size of the image and 
> therefore crashes.
> I have tried with few initrd images ranging between 300MB and 400MB, but 
> result was the same. I have tried to load the kernel with "initrd_addr_max" 
> set to 1GB, but no success.
> On the other hand everything works well when I boot with an initrd that is 
> around 70MB big.
> The Grub version I use is 2.04-1ubuntu26.9.
> Does anybody have an idea what the problem is and in which direction I could 
> go with troubleshooting?
> Many thanks!
> Vuk Gojnic
> Deutsche Telekom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]