[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub freezes when it touches large initrd

From: Vuk.Gojnic
Subject: Grub freezes when it touches large initrd
Date: Wed, 2 Jun 2021 15:02:56 +0000

Hello everybody,

I am fighting with one issue since two months and still could not get to the 
bottom of it.

Namely I am trying to boot the system with an initrd that is 406MB (gzip 
compressed) in size on x86_64 system with 256G RAM via UEFI. I use bootloader 
binaries (GRUBX64.efi and BOOTX64.efi) from Ubuntu Bionic. Kernel is also from 
the same distro.

When I get to Grub prompt I can normally load the kernel with:
Grub>linuxefi /vmlinuz

Howewer when I try to load initrd the Grub crashes and what follows is "red 
screen of death" with:
X64 Exception Type 0x03 - Breakpoint Exception
CALL ImageBase        ImageName+Offset
00h  0000000000000000 No Image Information

CALL ImageBase        ImageName+Offset

The same happens even if I just try to do "ls -la" on the directory that 
contains that initrd. If I do "ls" only it does not happen. I assume in former 
case it tries to calculate the size of the image and therefore crashes.

I have tried with few initrd images ranging between 300MB and 400MB, but result 
was the same. I have tried to load the kernel with "initrd_addr_max" set to 
1GB, but no success.

On the other hand everything works well when I boot with an initrd that is 
around 70MB big.

The Grub version I use is 2.04-1ubuntu26.9.

Does anybody have an idea what the problem is and in which direction I could go 
with troubleshooting?

Many thanks!

Vuk Gojnic
Deutsche Telekom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]