[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 'error: invalid signature' when booting Windows 10

From: David Collier
Subject: Re: 'error: invalid signature' when booting Windows 10
Date: Mon, 10 Dec 2018 13:59:37 -0800

On Mon, Dec 10, 2018 at 1:47 PM Pascal Hambourg <address@hidden>

> Le 09/12/2018 à 22:04, David Collier a écrit :
> > I am trying to retire an old HD where grub /boot directory happens to
> > reside, so I am trying to move it to the current Linux root partition
> which
> > is on an SSD.
> Did you move/reinstall a new GRUB in an EFI partition on the SSD too ?

I copied the script below to the SSD /etc/grub.d  directory and ran
update-grub, and verified that the menu shown when booting comes from this
grub instance.

> this is the script used to provide a Windows boot option in the Grub menu:
> >
> > vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
> > #!/bin/sh
> > exec tail -n +3 $0
> > menuentry "Windows 10" {
> >     insmod fat
> >     insmod chain
> >     insmod part_gpt
> >
> >     set root=(hd1,gpt3)
> >     chainloader /efi/Microsoft/Boot/bootmgfw.efi
> > }
> > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> >
> > the problem is that when trying to pick this option from grub menu when
> > booting from the new location, it reports 'error: invalid signature'. The
> > same menu worked fine when it was booting from the old disk (I made
> double
> > checked that (hd1,gptr) points at the correct partition).
> I assume you checked the (hdN) drive number did not change.

yes, I verified that it points to the correct hd and gpt by running the ls
command in the grub command mode.

> For now, the only explanation which comes to my mind is that the active
> GRUB is not GRUB EFI but GRUB BIOS, which expects to chainload a boot
> sector with AA55 signature instead of an EFI executable.

is there any way around this? I could reinstall windows if necessary - do I
need to initialize the SSD in a certain way?

Also, note that linux kernel which is booting now, when grub is co-located
with the linux root file system, is exactly the same I was booting before
this migration when grub was located on the HD being retired, but I can't
boot windows any more neither from new nor from old storage device, getting
the same error in both cases.

thank you,

> Help-grub mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]