[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issue with Super Grub2 Disk Hybrid and HP Detachable X2

From: adrian15
Subject: Re: Issue with Super Grub2 Disk Hybrid and HP Detachable X2
Date: Thu, 14 Dec 2017 07:32:50 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0

El 12/12/17 a las 11:43, Michel Bouissou escribió:
> Hi again,
> Le 10/12/2017 à 23:31, adrian15 a écrit :
>> 2. Can you please try Super Grub2 Disk Hybrid with the DD method?
> I have downloaded Super Grub2 iso image per your link and burnt it on a
> USB stick using dd.

> Not having the machine that causes me trouble with me, I tried the Super
> Grub2 stick on another one : An HP Pavilion Detachable X2 10-N123NF

> On this machine is currently only installed Manjaro Linux in UEFI (64)
> mode. (this machine is a tablet-like that seems to have no provision for
> booting legacy/CSM).
An UEFI only machine. Nice.

> It's booting with grub2. Works good. Never had any BIOS issue.
I understand. You are saying that it's booting with Manjaro's grub2.

> Now I have to report a serious issue with Super Grub2 on this machine :
> - Super Grub2 boots to its menu (Showing version 2.02s10-beta5)

> - I tried the "Print devices/partitions" option : Result : I get a
> screen of output followed by a [MORE] prompt, but at this step the
> computer is frozen. The usual "more" keys (Enter, space...) produce
> nothing.  Had no other solution than power cycling the computer the hard
> way.
I think it's the first time I have this feedback with this option.

> - Reboot into the Manjaro OS to check that everything was still good (it
> was), then reboot into Super Grub2

> - Tried the "Detect and show boot methods" option : Screen went black
> with the USB key access LED blinking fast, so I thought it was doing
> something... But after 10 minutes it still was, and then I had no other
> solution than to power-cycle the machine the hard way again.
I see. Well, sometimes, Super Grub2 Disk takes a while to find all the
installed Operating Systems. Do you have anything else than Manajaro in
your system? Maybe many EFI files or many ISO files at /boot/boot-isos/ ?

I also want to say that Super Grub2 Disk when using "Detect and..."
sources the installed grub.cfg files. Maybe that might be a problem in
some machines.

You can alternatively use the option: Boot Manually -> Operating Systems
so that in only searches kernels (and not sources grub.cfg files).

In such case do you happen to find also the UEFI CMOS memory corrupt
warning (that you describe in a moment) ?

> - At reboot, got a bad message stating that the UEFI CMOS memory was
> corrupt (scream !) so type press a key to fix it, which I did.
That does not make sense. As far as I know GRUB is read only in matter
of UEFI CMOS. I mean Super Grub2 Disk is just upstream GNU/GRUB with
some default build options.

I will have to ask GRUB gurus at grub-devel if GRUB is able to modify
UEFI entries by itself or not.

> - Then the machine rebooted to a « Windows failed to start » error
> message. After minutes of terror I discovered that all of my machine
> UEFI settings (except for the administrator password) had been reverted
> back to default settings (probably following the CMOS corruption) and
> that the "Secure boot" option had been reactivated.
Well, that might be a consequence of you saying "Yes" when you are asked
to fix the UEFI CMOS memory. Not a Super Grub2 Disk consequence. But,
it's true, that it would be nice to know why your UEFI BIOS is detecting
that the UEFI CMOS is corrupt after Super Grub2 Disk is used.
> - After deactivating it the machine would accept to boot Manjaro again,
> BUT while booting I noticed it doing unusual fsck stuff...
Maybe it was mounted more than X days ago or N times?

> So I can say for sure that Super Grub2 did something really bad to this
> machine - hadn't had a single UEFI CMOS corruption issue before, I don't
> believe it to be a bare coincidence...
> Hope that this information may be useful ?
Yes, it's useful. I might try to build another Super Grub2 Disk beta in
the next weeks (busy working on Rescatux right now) that does not
'source grub.cfg files' by default on the "Detect and..." so that you
can test it.

In the meanwhile you could test all the options of the current SG2D
2.02s10-beta5 version, one after another, in the "Boot Manually" menu
till you find which one is the culprit.

In theory, if my suspicion is right the culprit option would be:
"grub.cfg - Extract entries".

Thank you for your feedback!

Keep me informed if you do more tests in this machine.
Feel free to make backups before using SG2D if you are too scared of the
UEFI CMOS corrupted warnings.


Support free software. Donate to Super Grub Disk. Apoya el software
libre. Dona a Super Grub Disk.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]