[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issue with Super Grub2 Disk Hybrid and HP Detachable X2

From: Michel Bouissou
Subject: Re: Issue with Super Grub2 Disk Hybrid and HP Detachable X2
Date: Tue, 12 Dec 2017 11:43:16 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0

Hi again,

Le 10/12/2017 à 23:31, adrian15 a écrit :
> 2. Can you please try Super Grub2 Disk Hybrid with the DD method?

I have downloaded Super Grub2 iso image per your link and burnt it on a
USB stick using dd.

Not having the machine that causes me trouble with me, I tried the Super
Grub2 stick on another one : An HP Pavilion Detachable X2 10-N123NF

On this machine is currently only installed Manjaro Linux in UEFI (64)
mode. (this machine is a tablet-like that seems to have no provision for
booting legacy/CSM).
It's booting with grub2. Works good. Never had any BIOS issue.

Now I have to report a serious issue with Super Grub2 on this machine :

- Super Grub2 boots to its menu (Showing version 2.02s10-beta5)

- I tried the "Print devices/partitions" option : Result : I get a
screen of output followed by a [MORE] prompt, but at this step the
computer is frozen. The usual "more" keys (Enter, space...) produce
nothing.  Had no other solution than power cycling the computer the hard

- Reboot into the Manjaro OS to check that everything was still good (it
was), then reboot into Super Grub2

- Tried the "Detect and show boot methods" option : Screen went black
with the USB key access LED blinking fast, so I thought it was doing
something... But after 10 minutes it still was, and then I had no other
solution than to power-cycle the machine the hard way again.

- At reboot, got a bad message stating that the UEFI CMOS memory was
corrupt (scream !) so type press a key to fix it, which I did.

- Then the machine rebooted to a « Windows failed to start » error
message. After minutes of terror I discovered that all of my machine
UEFI settings (except for the administrator password) had been reverted
back to default settings (probably following the CMOS corruption) and
that the "Secure boot" option had been reactivated.

- After deactivating it the machine would accept to boot Manjaro again,
BUT while booting I noticed it doing unusual fsck stuff...

So I can say for sure that Super Grub2 did something really bad to this
machine - hadn't had a single UEFI CMOS corruption issue before, I don't
believe it to be a bare coincidence...

Hope that this information may be useful ?

Michel Bouissou <address@hidden> OpenPGP ID 0xEB04D09C

reply via email to

[Prev in Thread] Current Thread [Next in Thread]