[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GRUB2 does not start within a partition

From: Conrad Kostecki
Subject: Re: GRUB2 does not start within a partition
Date: Sat, 07 Apr 2012 01:30:18 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20120327 Thunderbird/11.0.1

Am 07.04.2012 00:19, schrieb Jordan Uggla:
> On Fri, Apr 6, 2012 at 7:23 AM, Conrad Kostecki <address@hidden> wrote:
>> Hi,
>> i've some problems, that I am unable to start GRBU2 from a partition.
>> I am using Win7, which is encrypted with Truecrypt. In order to boot
>> GRUB2 from a partition, I can press ESC in Truecrypt, to boot this one.
>> This setup was working for about 9 months now without any problems.
>> Today, I am unable to boot anymore. After launching GRUB2 from an
>> partition via Truecrypt, I get only "GRUB" and thats it. Nothing happens
>> anymore. I tried to chroot and install GRUB2 again, but it didn't
>> helped. Still not booting.
>> Can I debug this somehow? I don't know where to start..
>> P.S. I am using 2.00-Beta3.
>> Thanks!
>> Conrad
>> _______________________________________________
>> Help-grub mailing list
>> address@hidden
> Installing any bootloader without an embedded area requires blocklists
> pointing to blocks on an active filesystem, which is unreliable and
> insecure. It shouldn't be a surprise that it stopped working, as many
> normal filesystem operations could have moved the blocks around, but
> re-running grub-install should have fixed it again (at least
> temporarily). What grub-install command did you run and what did it
> output?

grub2-install --debug /dev/sda3
Short log:
/usr/sbin/grub2-bios-setup: Warnung: Dateisystem »ext2« unterstützt
keine Einbettungen.
/usr/sbin/grub2-bios-setup: Warnung: Einbettung ist nicht möglich. GRUB
kann in dieser Konfiguration nur mittels Blocklisten installiert werden.
Blocklisten sind allerdings UNZUVERLÄSSIG und deren Verwendung wird
daher nicht empfohlen..
installation beendet. Keine Fehler aufgetreten.

grub2-install --force --debug /dev/sda3
Attaching Long Log.

Btw, lilo works fine. At least, my GRUB-CFG must be ok, as booting via a
GRUB-CD works fine. Only GRUB seems not being chainloaded.


Attachment: grub-install.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]