[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GRUB2 does not start within a partition

From: Jordan Uggla
Subject: Re: GRUB2 does not start within a partition
Date: Fri, 6 Apr 2012 15:19:04 -0700

On Fri, Apr 6, 2012 at 7:23 AM, Conrad Kostecki <address@hidden> wrote:
> Hi,
> i've some problems, that I am unable to start GRBU2 from a partition.
> I am using Win7, which is encrypted with Truecrypt. In order to boot
> GRUB2 from a partition, I can press ESC in Truecrypt, to boot this one.
> This setup was working for about 9 months now without any problems.
> Today, I am unable to boot anymore. After launching GRUB2 from an
> partition via Truecrypt, I get only "GRUB" and thats it. Nothing happens
> anymore. I tried to chroot and install GRUB2 again, but it didn't
> helped. Still not booting.
> Can I debug this somehow? I don't know where to start..
> P.S. I am using 2.00-Beta3.
> Thanks!
> Conrad
> _______________________________________________
> Help-grub mailing list
> address@hidden

Installing any bootloader without an embedded area requires blocklists
pointing to blocks on an active filesystem, which is unreliable and
insecure. It shouldn't be a surprise that it stopped working, as many
normal filesystem operations could have moved the blocks around, but
re-running grub-install should have fixed it again (at least
temporarily). What grub-install command did you run and what did it

Jordan Uggla (Jordan_U on

reply via email to

[Prev in Thread] Current Thread [Next in Thread]