[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: booting from a raid1

From: Chris Weber
Subject: Re: booting from a raid1
Date: Fri, 8 Oct 2010 08:30:49 -0500

On Fri, Oct 8, 2010 at 4:12 AM, lee <address@hidden> wrote:
> On Fri, Oct 08, 2010 at 12:40:59AM -0700, Jordan Uggla wrote:
>> On Fri, Oct 8, 2010 at 12:25 AM, lee <address@hidden> wrote:
>> > Hmm ... Ok, I just tried with a separate /boot partition mounted
>> > directly under /boot on the root partition, but grub-install doesn't
>> > create a grub.cfg.
>> grub-install never creates a grub.cfg, that's what grub-mkconfig is for.
> Hm, well, ok, I created a grub.cfg with grub-mkconfig and edited it:
> [...]
> menuentry 'Debian GNU/Linux, with Linux' --class debian --class 
> gnu-linux --class gnu --class os {
>        insmod part_msdos
>        insmod ext2
>        insmod raid
>        insmod mdraid
>        set root='(/dev/sdd,msdos1)'
>        search --no-floppy --fs-uuid --set e62e0c56-2531-4ec4-a839-1835b8b0a8cc
>        echo    'Loading Linux ...'
>        linux   /vmlinuz- iommu=noaperture root=/dev/md0p2 ro
> }
> [...]
> Now I can boot from /dev/sdd, but the kernel panics because it can't
> mount the root filesystem (/dev/md0p2). Entries in /etc/fstab on md0p2
> are correct. I take it the md-devices aren't up/accessible in time.
> Any idea what's missing? Like there's no RAID support in grub?
> _______________________________________________
> Help-grub mailing list
> address@hidden

Have you made a new initrd that has md and/or raid support?  I ran
into a similar problem when using grub2 to boot off of an LVM
partition.  I had to add a couple modules to the initrd /lib and edit
the init script to load them.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]