[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: booting from a raid1

From: Tom H
Subject: Re: booting from a raid1
Date: Fri, 8 Oct 2010 15:14:24 -0400

On Fri, Oct 8, 2010 at 3:25 AM, lee <address@hidden> wrote:
> On Tue, Oct 05, 2010 at 11:22:35PM -0400, Tom H wrote:

>> I tried to re-create your setup in VBox. I looked for an option to
>> create a partitioned md device through d-i but it can only create a
>> non-partitioned device AFAICT. I also created a partitioned md device
>> using another install but I couldn't figure out, after running the
>> initial mdadm creation command, what to do next to carve out the
>> partitions and size them before booting from d-i to perform
>> installation. I must be missing something crucial here but no amount
>> of reading mdadm's man page or googling has helped me figure out the
>> next step... And d-i only sees one raid device.

> The Debian way seems to be to use LVM ... I think the d-i can create a
> partitioned RAID, but I don't remember exactly. But it will fail to
> install grub when you do that, I tried ...

With d-i, you can specify regular disks, mdadm, lvm, or combination of
mdadm and lvm.

> Anyway, once you create an md-device, like /dev/md0, just use fdisk on
> it (as in "fdisk /dev/md0"). You can partition it just like a physical
> block device.

I didn't know that (since I've never used partitionable md devices, thanks).

I've recreated a partitioned md0 and tried to install squeeze onto it.
The install failed at the grub stage. I'll try when I next have time
to chroot the install and try "grub-install" but I have my doubts
about the likelihood of success...

> You've gone to great lengths trying to help --- thank you very much!

You're welcome.

>> If you want to have "/boot" on a separate non-mdadm'd disk, say sdg
>> (I've lost track of your disks but I think that it is the next
>> letter...), "/boot" can be "/dev/sdg1" and you'd then run
>> "grub-install /dev/sdg".
> Meanwhile, I got the SATA cables I needed. So now I have an SATA disk
> connected I can try to use to put a /boot partition on. But when
> grub-install doesn't create a grub.cfg --- which it doesn't --- it
> still won't work. And there could still be a problem with getting
> /dev/md0 up and running so that /dev/md0p2 can be used as the root
> partition.
> Hmm ... Ok, I just tried with a separate /boot partition mounted
> directly under /boot on the root partition, but grub-install doesn't
> create a grub.cfg.
> The only way is probably to move the whole root partition to that SATA
> disk and boot from that. At least that will allow me to remove the IDE
> disk, but I won't have the root partition on a RAID.
> So much to RAID support in grub :(( I wonder if I should file a bug
> report? It's a bug that should be fixed before the next release of
> Debian stable since it prevents installation altogether.

grub-install doesn't create grub.cfg. You need to run "update-grub"
(on Debian and Ubuntu, it's a script that calls grub-mkconfig).

grub's not going to care about being able to recognize md0p2 because
it'll be activated by your initrd.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]