[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub2: config seems ok, but no automatic startup

From: Hugo Mercier
Subject: Grub2: config seems ok, but no automatic startup
Date: Tue, 28 Sep 2010 10:18:14 +0200

Hi all,

I am trying to install grub on a 200 GB SSD (OCZ Vertex2 Pro, in
SATA2). This is the only disk installed on the computer.
Legacy grub seemed to have problem reading partitions on it (the
partition type was correctly recognized (ext2) but no file could be
accessed (bad file or directory).

I thus installed grub2 on it. I am using the last version (1.8)
freshly downloaded and compiled.

The system has been boostrapped using the Ubuntu installer to install
grub2. I then overwrote the system's partition with the system I want
to boot on (based on CentOs, but whatever)
I achieved to boot manually from the grub shell (using linux, initrd
and boot commands).
I then installed the new grub 1.8 and reinstall it on the mbr.
Everything seemed fine (grub-install is ok), but when I rebooted the
system, I could only get the grub shell and nothing happened. If I
typed "configfile /boot/grub/grub.cfg" it worked perfectly, I had a
nice menu from where I could choose and boot my system.
I checked with "set" that $prefix is correctly set.

I also tried the same hard disk on another motherboard, and the result
is the same. It is probably unrelated to the BIOS or SATA controller.

I can't figure out what I am doing wrong with the grub configuration.
Is there someone here with an idea ?
Thanks in advance.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]