[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

EFI boot on non Mac hardware.

From: Cedric Lejeune
Subject: EFI boot on non Mac hardware.
Date: Tue, 01 Jun 2010 15:45:02 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100317 Thunderbird/3.0.4

Hello list,

I have bought a EFI capable notebook (ASUS G73GH, x86_64, MegaTrend BIOS) and I am trying to fully boot Linux (Debian) using EFI. I first partitioned my disk using GPT and allocated some space to the ESP. Then I installed Debian package grub-efi-amd64, used grub-install and grub-mkconfig to generate grub.efi and grub.cfg config file and check everything was on the ESP, including *.mod, *.lst and the like. I added a new entry in my boot menu pointing to grub.efi, saved changes and choose the newly added entry. The screen resolution changed and a prompt appeared at the top left corner of the screen and tada! Epic fail... Blank screen. So I tried using grub-efi-ia32, same result. Next, I tried with grub-1.98 sources using grub wiki and as references and once again, blank screen.

So I give a try using Windows 7: EFI boot install DVD, wipe GPT from the install disk and let Windows 7 installer manage everything. At the end of the installation, a new boot entry was added to my boot menu and I could fully boot Windows 7 using it. So, I guess that means my notebook is really EFI capacble, right?

I then tried to install and use Shell_Full.efi from EDK, added a new entry to my boot menu and everything worked fine. I have tried rEFIt too and it kinda worked (it complain about vollabel?). But at least, I was seeing something one my screen. Manually added entry to boot Windows 7 worked too.

So here come the questions:
1. Is there some way to precisely know which modules I have to include when I generate grub.efi? 2. Is there a way to make grub more verbose? Or a debug mode? Something that would let me know at which step the boot sequence is? Or a way to use EFI shell to run grub in verbose mode? To sum up, I would like some log to track down what is wrong with my current setup.
3. How could I check the problem is not due to my BIOS?

I have already took a look at the mailing list, but a lot of (all?) EFI issues are Mac related (no 'bless' command on Linux for instance).

Thank you for your help.

Kind regards,


Attachment: cedric_lejeune.vcf
Description: Vcard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]