[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "Unknown partition table signature" when installing GRUB onto EXT2

From: Michael Evans
Subject: Re: "Unknown partition table signature" when installing GRUB onto EXT2 floppy
Date: Wed, 23 Sep 2009 13:16:30 -0700

I created a 1440KB image and forced mkfs.ext2 to run on it.  This is top of the hexdump for that file.

00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000400  b8 00 00 00 a0 05 00 00  48 00 00 00 71 05 00 00  |........H...q...|
00000410  ad 00 00 00 01 00 00 00  00 00 00 00 00 00 00 00  |................|

You might note how only 1kb of free space remains at the start of the file (device)?  That is not enough space for a stage 1.5 image.  However you should probably be able to force a stage 1 install by manually using an invocation including this:

For me the first works:
grub --device-map=/media/vfloppy/grub/
Unknown partition table signature

       [ Minimal BASH-like line editing is supported.   For
         the   first   word,  TAB  lists  possible  command
         completions.  Anywhere else TAB lists the possible
         completions of a device/filename. ]
grub> root (fd0)
root (fd0)
grub> setup (fd0)
setup (fd0)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (fd0)"... failed (this is not fatal)
 Running "embed /boot/grub/e2fs_stage1_5 (fd0)"... failed (this is not fatal)
 Running "install /boot/grub/stage1 (fd0) /boot/grub/stage2 p /boot/grub/menu.lst "... succeeded

1) The virtual floppy is mounted.
2) The virtual floppy contains stage1 and stage2 inside of grub/
3) The virtual floppy has a symlink 'boot' which points to .  (e.g. cd /media/vfloppy ; ln -s . boot )
4) I have prepared a file and provided it to the grub shell to tell grub that at boot time 'fd0' will actually match the loopback adapter currently in use.

=== Contents of ===
(fd0)   /dev/loop0

The Install command can also be invoked manually, you should give it a good reading to understand what the last step above accomplished.

On Wed, Sep 23, 2009 at 12:46 PM, Ersin Akinci <address@hidden> wrote:
Hi all,

I'm not sure if this is a bug or if what I'm trying to do is simply
unsupported, but I'm trying to install GRUB (0.97) onto a floppy
formatted as ext2 and I keep getting the error "unknown partition
table signature".  Here's what I've been doing:

$ mke2fs /dev/fd0
$ mount /dev/fd0
$ mkdir -p /media/floppy/boot/grub
$ cp /boot/grub/stage* /media/floppy/boot/grub
$ umount /dev/fd0

Then, at the GRUB prompt:

grub> root (fd0)
Unknown partition table signature

Trying to do setup (fd0) after that also results in an error.  My
media is not the problem, because I've also tried doing the same thing
using a disk image mounted as a loopback device, which still gives the
same error.  Looking around on the Internet, it seems like this is a
common problem, but no one has a solution.

Also, I can't use the instructions at
(which tell the user to dd stage1 and stage2 to the beginning sectors
of the floppy) because I need to use the rest of the disk.

I take it that floppies aren't meant to have partition tables and
partitions like hard drives...?  But then what is GRUB complaining

Any ideas?


Help-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]