[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

"Unknown partition table signature" when installing GRUB onto EXT2 flop

From: Ersin Akinci
Subject: "Unknown partition table signature" when installing GRUB onto EXT2 floppy
Date: Wed, 23 Sep 2009 15:46:24 -0400

Hi all,

I'm not sure if this is a bug or if what I'm trying to do is simply
unsupported, but I'm trying to install GRUB (0.97) onto a floppy
formatted as ext2 and I keep getting the error "unknown partition
table signature".  Here's what I've been doing:

$ mke2fs /dev/fd0
$ mount /dev/fd0
$ mkdir -p /media/floppy/boot/grub
$ cp /boot/grub/stage* /media/floppy/boot/grub
$ umount /dev/fd0

Then, at the GRUB prompt:

grub> root (fd0)
Unknown partition table signature

Trying to do setup (fd0) after that also results in an error.  My
media is not the problem, because I've also tried doing the same thing
using a disk image mounted as a loopback device, which still gives the
same error.  Looking around on the Internet, it seems like this is a
common problem, but no one has a solution.

Also, I can't use the instructions at
(which tell the user to dd stage1 and stage2 to the beginning sectors
of the floppy) because I need to use the rest of the disk.

I take it that floppies aren't meant to have partition tables and
partitions like hard drives...?  But then what is GRUB complaining

Any ideas?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]