[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Motherboard change = can't boot

From: D T
Subject: Re: Motherboard change = can't boot
Date: Thu, 7 May 2009 11:20:29 -0700 (PDT)

I think I had a similar problem 3 or 4 year ago. In my case the drivers for the new HDD controllers on the MB were not compiled in the kernel. 

If you haven't tried this yet:

Boot from a Gentoo CD

Run lspci to see what you have on the MB

Do something of this sort: mount the root partition, cd to /usr/src/linux and check if the drivers for the HDD controllers are compiled in the kernel, by taking a look in the ".config" file or running "make menuconfig". You may have to chroot (not sure) and recompile the kernel & modules.

You may also want to look at /proc/partitions to see what's being recognized.

Hope someone more experienced can add the missing details.


	Date: Wed, 06 May
 2009 22:32:03 +1000
From: Richard Mullins <address@hidden>
Subject: Motherboard change = can't boot
To: address@hidden
Message-ID: <address@hidden>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed


I have just changed motherboard and now i can't boot. It seems to be an 
issue with the drive order. I get the grub menu and can use find to 
confirm that it thinks the files are in hd0,0 and it starts the boot 
process ok but halts with a kernel panic when trying to determine the 
root partition.

I have 6 drives in the machines, 4 sata drives in a raid-5 array and 2 
IDE drives, one of which has the OS (Gentoo). When the kernel loads it 
seems as though the SATA drives are 0-3 and in this case the boot drive 
is 4. I thought it must be the root= kernel parameter (it was previously 
set to /dev/hda3) so iI have tried every combination (/dev/hde3, 
/dev/sde3/ hda, sda, etc, etc) but nothing seems to work. Each time it 
would kernel panic with the message to select one of the listed 
partitions for the root= entry. At first it only showed the 4 sata 
drives then I found a legacy setting in the bios and turned it off, now 
it shows nothing.

Is this a grub issue or a kernel issue (or something else)?

When I boot off a USB key (Ubuntu) i have see all the drives and I even 
mounted and chrooted in the gentoo drives and installed a new kernel (I 
was running out of ideas).

I am running Gentoo, GRUB V0.97, Kernel 2-6.28.

Any suggestions would be most welcome.

Richard Mullins

reply via email to

[Prev in Thread] Current Thread [Next in Thread]