[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: unassigning cntl-Z in cua mode

From: Stuart McGraw
Subject: Re: unassigning cntl-Z in cua mode
Date: Sun, 22 Mar 2015 22:54:01 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0

On 03/22/2015 10:44 PM, Alexis wrote:
On 2015-03-23T15:21:51+1100, Stuart McGraw <> said:

SM> Hello all,

SM> I have recently started using CUA mode and it is ok except for SM>
one thing... I don't like having cntl-z mapped to undo. I run SM> emacs
in a terminal window (emacs -nw) a lot and routinely need SM> to suspend
emacs with cntl-z, do something in the shell, then SM> resume emacs.

SM> How can I undo the mapping the CUA mode applies to the cntl-z SM>
key?  I am elisp-illiterate so a cut and paste solution would be SM>
greatly appreciated.

(global-unset-key (kbd "C-z"))

might do the trick ....

Ah, I was try to set it to nil.
I just tried your suggestion instead but still no joy.
No errors or messages but no effect either, ctrl-z still
tries to do an undo.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]