help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem running graphical GNU Emacs 24


From: Tom Roche
Subject: Re: problem running graphical GNU Emacs 24
Date: Fri, 25 Nov 2011 11:22:32 -0500
User-agent: GNU Emacs 24.0.91.1 (x86_64-pc-linux-gnu, GTK+ Version 2.20.1)

summary: on debian, installing both packages

emacs-snapshot-gtk emacs-snapshot-nox

causes the latter to disable the former. Is this working as designed, or a bug? 
If a bug, where to report?

Tom Roche Thu, 24 Nov 2011 21:58:18 -0500
>> [After]

>> $ sudo aptitude install emacs-snapshot-el emacs-snapshot-gtk 
>> emacs-snapshot-nox

>> When I run

>> $ emacs --debug-init &

>> I get the graphical/X version of emacs [23], in a new window.
>> But when I run

>> $ emacs-snapshot --debug-init &

>> I get

>> > [1]+  Stopped                 emacs-snapshot --debug-init

>> which, after `fg 1`, runs emacs 24 in the terminal. I expected,
>> instead, the same behavior as emacs 23.

>> What must I do to start a graphical instance of emacs 24?

XeCycle Fri, 25 Nov 2011 23:44:32 +0800
> I guess the -gtk one is built with configure option
> `--with-x-toolkit=gtk'. A graphical one can always run in a
> terminal, I guess the -nox one is not needed.

And it does indeed seem that installing package=*-nox somehow disables
one's ability to run graphically:

$ sudo aptitude remove emacs-snapshot-nox
...
> The following packages will be REMOVED:  
>   emacs-snapshot-nox 
...
> The following packages have unmet dependencies:
>   emacs-snapshot-gtk: Depends: emacs-snapshot but it is not going to be 
> installed.
> The following actions will resolve these dependencies:
>      Remove the following packages:
> 1)     emacs-snapshot-gtk          
> Accept this solution? [Y/n/q/?] Y
> The following packages will be REMOVED:
>   emacs-snapshot-gtk{a} emacs-snapshot-nox 
...                                         
$ sudo aptitude install emacs-snapshot-gtk
> The following NEW packages will be installed:
>   emacs-snapshot{a} emacs-snapshot-gtk 
...

And after that,
                                         
$ emacs-snapshot-gtk --debug-init &

performs as expected. That seems to me like a bug: is it? If so, where
to report (e.g., to emacs, to the package maintainers, other)?

TIA, Tom Roche <address@hidden>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]