help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: remote tramp hangs


From: Tim X
Subject: Re: remote tramp hangs
Date: Wed, 02 Dec 2009 21:15:27 +1100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.50 (gnu/linux)

address@hidden (Raphaël Berbain) writes:

> * Michael Albinus:
>
>> You have posted the contents of the *Messages* buffer, and the backtrace
>> when you have quit Tramp. I do not see the *debug tramp/scp address@hidden
>> buffer.
>
> Have a look at line 180 & after in my first post.
>
>> Am I blind?
>
> Either that, or I am dense <g>.

Not sure about anyone else, but I am blind! I have possibly missed the
vital post, but the one I saw with debug was only the debug stuff from
ssh, nothing from tramp. 

However, I did have a thought....

If you can connect via tramp to a user account OK, but it appears to
fail when you attempt to connect as root AND if you are able to connect
as root just using ssh outside of emacs/tramp, then my guess would be
that tramp may be having problem detecting the shell prompt. 

On most Linux boxes, the prompt you get as a regular user is slightly
different from the prompt you get when logged in as the root user. I
have had problems with tramp in the past where the prompt was different
from what you normally get (so different that tramp got confused and
failed to connect). 

This is just a shot in the dark and may not be the issue, but thought it
was worth mentioning. 

The tramp debug output may shed more accurate info.

Tim

-- 
tcross (at) rapttech dot com dot au


reply via email to

[Prev in Thread] Current Thread [Next in Thread]