[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: easy-menu: wrong-type-argument keymapp

From: Drew Adams
Subject: RE: easy-menu: wrong-type-argument keymapp
Date: Sat, 28 May 2005 09:08:24 -0700

     GNU Emacs 21.2.1 (i686-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
     I haven't tried Emacs-CVS, and would probably wait until
     I finish switching over to a slackware 10 partition, as
     I'm in the process of moving off of this RH partition.

     Looks like it is just the "file" path/menu that is creating
     a problem.

Ah, File only - that rings a bell. I ran into this when trying to use a
version of printing.el that fit with an older (mid 2004) version of Emacs.

I believe that the problem is the version of Emacs you are using and its fit
with your code wrt the File option. At some point last year, they changed
the internal name of the File option. Here is what Vinicius Latorre
(printing.el author) wrote to me about that:

    I don't remember the exact date when Emacs changed the internal
    name of File
    option.  Some time ago the internal name was "files", but from
    some date the
    internal name was renamed to "file".  So, using v6.8.3 (the latest
    printing) in
    old Emacs gives the error above.  Also, using v6.8 (old
    printing) in latest
    Emacs gives the same error.  The internal name changing
    happened in version
    21.3.50 (I guess).

In sum, the library (code) that you use must fit the version of Emacs



reply via email to

[Prev in Thread] Current Thread [Next in Thread]