[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Printing - At Wit's End

From: Michael Flynn
Subject: Re: [h-e-w] Printing - At Wit's End
Date: Mon, 23 Jul 2012 16:04:18 -0700

I changed the path to C:\PROGRA~!  as you suggested, but that gave an
error that it could not find the file.
I reinstalled 32bit and 64bit ghostscript in places with blander names
and changed the settings in .emacs thus:

 (setenv "GS_LIB" "C:/Ghostscript/gs905/32bit/lib")
(setq ps-lpr-command "C:/Ghostscript/gs905/32bit/bin/gswin32c.exe")
(setq ps-lpr-switches '("-q" "-sDEVICE=mswinpr2" "-dNOPAUSE" "-dBATCH"))
(setq ps-printer-name t )

and I made sure the new bin and lib directories are in the dos
environment variable PATH.

If I M-x ps-print-buffer and send it to an HP printer I see a little
window come up with some status.  It is an HP utility or part of the
driver, but it says:

Ghostscript output
Job sent to printer
Job sent to printer

but nothing prints.

If I run the gswin32c.exe command from a DOS Prompt window with the
options as above, the little status window from HP says:
Ghostscript output
Job sent to printer
Processing job
Printing from Tray 4

and it prints just fine.

So it looks like its getting out of Emacs and going to at least the
driver on the Windows 7 machine, but there's something different about
the output from Emacs to the output from gswin32c.exe run from DOS.


On Mon, Jul 23, 2012 at 12:33 PM, Eli Zaretskii <address@hidden> wrote:
>> Date: Mon, 23 Jul 2012 11:42:12 -0700
>> From: Michael Flynn <address@hidden>
>> Eli,
>> I invoked ps-print-buffer with an arg and saved the .ps file.
>> Then from a DOS Prompt window I typed:
>>  gswin64c.exe -q -dNOPAUSE -dBATCH -sDEVICE=mswinpr2
>> and it worked!  It prompted me for a list of printers, I chose one,
>> then the file printed OK. :)
> That's good progress.
>> So, I entered these lines into the .emacs and started emacs with no options:
>> (setenv "GS_LIB" "C:/Program Files/gs/gs9.04/lib")
>> (setq ps-lpr-command "C:/Program Files/gs/gs9.04/bin/gswin64c.exe")
>> (setq ps-lpr-switches '("-q" "-sDEVICE=mswinpr2" "-dNOPAUSE" "-dBATCH"))
>> (setq ps-printer-name t )
>> If I try Mx ps-print-buffer  I am prompted for a printer; I choose a
>> printer, hit OK, and in *Messages* buffer see:
>> Printing...done
>> but nothing is sent to the printer
> Does it help to use "C:/PROGRA~!" instead of "C:/Program Files"?  (It
> avoids spaces in file names, which could cause failures in subtle and
> "interesting" ways.)
> If that doesn't work, the only other idea I have is to install a
> 32-bit build of Ghostscript, perhaps there's some problem with
> invoking a 64-bit one from within a 32-bit Emacs.

Michael Flynn
Attorney at Law

The information and any attachments contained in this email
message may be privileged, confidential, and protected from
disclosure. If you are not the intended recipient, any
dissemination or copying is strictly prohibited. If you
think that you may have received this email message in
error, please notify the sender at the email address above.
If you have received this email in error, you are instructed
to delete all copies and discard any printouts without
reading the information contained within.

IRS Circular 230 Disclosure:  To ensure compliance with requirements
imposed by the IRS, we inform you that any U.S. federal tax advice
contained in this communication (including any attachments) is not
intended or written to be used, and cannot be used, for the purpose
of (i) avoiding penalties under the Internal Revenue Code, or (ii)
promoting, marketing or recommending to another party any
transaction or matter addressed herein.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]