[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Printing - At Wit's End

From: Eli Zaretskii
Subject: Re: [h-e-w] Printing - At Wit's End
Date: Fri, 20 Jul 2012 23:32:44 +0300

> Date: Fri, 20 Jul 2012 11:25:37 -0700
> From: Michael Flynn <address@hidden>
> I'm going crazy trying to get postscript printing working.
> Previously, whenever I installed emacs on windows, I just needed to
> set the printer names and Hey Presto! it worked.

So what's different this time?  I mean, in your Windows version,
configuration, printers, Emacs version, whatever else?

> Installed ghostscript and gsview
> Ensured the .exe files were in the path.
> Put this (and a hundred different combos) in my .emacs
> ;; Set up printing
> (message "Set up printing")
> (setenv "GS_LIB" "C:/Program Files/gs/gs9.04/lib")
> (setq ps-lpr-command "C:/Program Files/gs/gs9.04/bin/gswin64c.exe")
> ;;(setq ps-lpr-command "C:/Program Files/Ghostgum/gsview/gsprint.exe")
>  ;; tried this too - no luck
> (setq ps-lpr-switches '("-q" "-query" "-dNOPAUSE" "-dBATCH"))
> ;;(setq ps-printer-name "//SCU-DS280R1/Dell 2145cn Color Laser MFP PS"
> )  ;; uncommenting this and taking -query option out of
> ps-lpr-switches does not affect behavior
> ;; end Set up printing

Did you use Ghostscript on your previous Windows installations?  Or
did printing work back then without Ghostscript?

> What happens is that print-buffer works but if I execute
> ps-print-buffer no errors appear but nothing much else happens.   If I
> watch the *Messages* buffer I see the message "Printing..." which soon
> changes to "Printing...done."   But nothing shows at the printer.
> If I try to exit Emacs, it warns that there are processes still
> running and do I really want to Exit.
> If from the windows command prompt I use gsprint to print a .pdf file,
> it prints ok.

If you save Emacs's PostScript output to a file, with

  C-u M-x ps-print-buffer RET

and then invoke gswin64c.exe via call-process using its full absolute
file name as set in ps-lpr-command, to print that file, does that

Btw, the Emacs manual also tells to set ps-printer-name to t, when you
use Ghostscript.  Did you do that?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]