[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using grub on fuloong 6004

From: David Kuehling
Subject: Re: Using grub on fuloong 6004
Date: Sun, 24 Jul 2011 14:54:48 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (gnu/linux)

>>>>> "Vladimir" == Vladimir 'φ-coder/phcoder' Serbinenko <address@hidden> 
>>>>> writes:

>> I also ran 'grub-install' once, which put a full set of grub modules
>> to /boot/grub.  However, it failed to generate a grub image and
>> complained:
>> $ sudo /usr/local/sbin/grub-install /usr/local/bin/grub-mkimage:
>> error: cannot stat /usr/local/lib/grub/mipsel-loongson/uhci.mod.
> Fix attached

Ok, with your latest uhci.diff, I can now just run 'grub-install' which
leaves a (somewhat) working grub.elf in /boot.  Feels like we're getting

This shows the same behaviour like the grub-diy.elf that I generated via

  - keyoard still not working.  Tried plugging in after grub startup,
  but doesn't help (for grub-diy.elf i had to shortly plug in the
  keyboard to select it in pmon, so mayb that doesn't count).  Also
  mouse was disconnected.

  - menu looks a little grabled (lots of '@' instead of border), but
  won't complain about that

Grub is already better working than Pmon.  Pmon refuses to load some of
my kernels without any indication why (seems to have problems depending
on image size, sometimes only vmlinux works, vmlinuz doesn't, kernels
compiled with -O2 don't work at all, need -Os etc.).

As far as I could test (without keyboard), grub now loads 3
kernels+initrd images that pmon would not load.


GnuPG public key:
Fingerprint: B17A DC95 D293 657B 4205  D016 7DEF 5323 C174 7D40

Attachment: pgpOOY9wjOql1.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]