[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using grub on fuloong 6004

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: Using grub on fuloong 6004
Date: Sat, 23 Jul 2011 14:00:01 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110626 Iceowl/1.0b2 Icedove/3.1.11

On 23.07.2011 13:11, David Kuehling wrote:
> Hi,
> I've been unsuccessful so far with making grub work on my Fuloong 6004
> box.  What I tried first wast the 'grub-yeeloong' package of debian
> squeeze, building a grub.elf as described in the debian-yeeloong wiki
> [1] (i.e. grub-mkimage --format=mipsel-yeeloong-elf ...)
> The resulting grub.elf only shows a black screen when loaded from pmon,
> and doesn't show any reactions.
> Then I found some mailinglist threads that refer to
> --format=mipsel-fuloong-elf (i.e. not "yeeloong").  Only the bzr trunk
> seems to have support for that.  Tried this thursday's trunk version,
> and built my image using
>   sudo grub-mkimage  --config=/boot/grub.elf.conf \
>      --output=/boot/grub3.elf --format=mipsel-fuloong-elf --verbose \
>       ata part_msdos ext2 reboot halt lspci ohci usbtest usbms linux \
>       fat xfs part_gpt multiboot2 minicmd configfile gcry_md5 hashsum
ata was renamed to pata.
> My /boot/grub.elf.conf reads
>   set root=ata0,msdos1
>   set prefix=($root)/grub
> My /boot partition is /dev/sda (ext3).
> however, this image now blanks the screen and shortly after reboots the
> fuloong when loaded from the pmon menu.
> Am I doing anything wrong?  Is Fuloong support known to be not (fully)
> functional?
Fuloong 2F support was fully functional when it was merged. It's
possible though that there was a recent regression. I'll retest today.
> cheers,
> David
> [1]
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Vladimir 'φ-coder/phcoder' Serbinenko

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]