[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Question] gpsd, ntrip & C94-M8P (u-Blox)

From: Florian Kiera
Subject: Re: [Question] gpsd, ntrip & C94-M8P (u-Blox)
Date: Tue, 12 May 2020 11:06:35 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.8.0

Hey Gary!

Am 11.05.20 um 20:49 schrieb Gary E. Miller:
Yo Florian!

On Mon, 11 May 2020 15:11:28 +0200
Florian Kiera <address@hidden> wrote:

Hey Gary!

Am 04.05.20 um 22:37 schrieb Gary E. Miller:
I run one I found as open source, (source of
information to ntrip) and (the
Thanks.  I'll try it.

No updates since 2014, except one link change in 2016.

It throws a ton of warnings...
Still seems like a possible work-around for a free caster. At least I
haven't experienced anything bad so far from it.
Best so far.

I don't see the GGA thing that is blocking gpsd on a lot of
Sounds good?
Not good.  The GGA thing is bad.
GGA is NMEA right? I only transmit rtcm messages what is it needed for on the caster?

I've got another question regarding the u-blox M8P:

The rover's green LED is flashing which the user guide is saying to
mean the M8P is in RTK Float mode (status).
No u-blox has any LED's.  So this must be related to the unspecfied
board your u-blox is on.

No way for us to understand without seeing your board doc.
C94-M8P ( The User Guide is descriping 2 LED's a blue one that flashes when its receiving GNSS/GPS data and a green LED which indicates whether the rover is in RTK float or RTK fix or even none of the named. If the green flashes its supposed to mean its in rtk float mode, without flashes (just a green light) its supposed to be in RTK fixed mode. As before the User Guidance just could be missing information at that point (may green flash also can indicate DGPS?)

I am using gpsd to receive all informations from the rover and check
the gps_data_t => status (github: gps_fix_t.status).
No one receives all the informamtion.
All necessary informations at the very least.

The status returns me a 2 (DGPS). How is that? Is it because my base
has a too less accuracy for RTK? (20m accuracy)
Last time you sent your config you had your base and rover configurations
wrong and I explained partly what was wrong.  Did you fix that?

Instead of me guessing if you fixed it, send us the output of this so we
can see:

         ubxtool -p STATUS -p CONFIG -P XX

Replace XX with your firmat version.  It is probably 17, 18 or similar.

base_conf.txt->output of the ubxtool on my base

rover_conf.txt->output of the ubxtool on my rover

Using latest gitlab version

Also ubxtool keeps resetting all my configurations anyways. Whenever I use the command all my rtcm msgs are disabled, protocol in and out are configured to nmea and ubx only, dynModel is changed as well...

If so could you please tell me what accuracy of the base I should
seek for? (What accuracy is needed for RTK?)
If the base is reporting surveyed in, then you are good.  No way to know if
that is a good as you need, but sufficient for RTK.

My target is to get the status 3 (RTK float) from the rover. My
assumption is that my base isn't accurate enough.
Wrong assumption.

You've got other
ideas that could improve it?
As in previous emails.  Awaiting confirmation you fixed things as
previously recommended.

The only things you suggested me in view of the M8P's so far was editing the dynModel (which was right all the time, might've mixed up rover and base conf text files?) and using survey-in for the base, which I applied before checking the gps_data_t.status.

Regards Florian

Attachment: base_config.txt
Description: Text document

Attachment: rover_config.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]