[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] Problem running on CentOS 7

From: Atul
Subject: Re: [gpsd-users] Problem running on CentOS 7
Date: Sat, 8 Apr 2017 10:44:15 +0530

On similiar Line, I am trying gpsd on ubutnu 16.04 LTS and what I get via apt installation, works fine when starts gpsmon and gpsd for a  Garmin USB gps.
But when I build this module , I get no NMEA output as in previous case. 
The output in this case is 3 rows ,one with version, 2nd with device and third with "watch" where I see NMEA as false.
Looks like by default NMEA s false and it need to be set enabled before building it. Anyone know where I can mark them enabled ?

Sorry I am new to json and don't know if gpsd_json.xml would be right place, still tried but did not work.
Any help is appreciated.

From: Tony Hain
Sent: ‎08-‎04-‎2017 00:03
To: 'JCH'; address@hidden
Subject: Re: [gpsd-users] Problem running on CentOS 7

From: gpsd-users [mailto:address@hidden On
Behalf Of JCH
Sent: Friday, April 07, 2017 4:30 AM
To: address@hidden
Subject: [gpsd-users] Problem running on CentOS 7

I've installed gpsd on CentOS7 Minimal (yum install gpsd).  The following
dependencies have been pulled in as well: bluez-libs, gpsd-libs, libusbx.
 It seems to start up fine automatically as a service, however, if I run it
from the command line, it produces no output.  Even running "gpsd -h"
produces no help output at all.  Seems like something pretty fundamental, so
I'm trying to figure out if there's a missing dependency or other
environment setup that I'm missing.

Any ideas as to what could be missing would be appreciated.

gpsd -h should produce output, but in normal runtime it does not. While gpsd
is running, run gpsmon or cgps, which will provide the UI side of the

reply via email to

[Prev in Thread] Current Thread [Next in Thread]