|Subject:||Re: [Getfem-commits] please merge branch devel-tetsuo-add_lumped_mass_python_interface_squash|
|Date:||Sat, 24 Apr 2021 16:04:48 +0900|
Dear Tetsuo,Thanks for tidying things up and testing. I have merged your branch. Maybe Yves will suggest some deprecation aliases for the old function names, but if so we can still add these later.BRKostasOn Wed, Apr 21, 2021 at 2:59 AM Tetsuo Koyama <email@example.com> wrote:Dear KostasThanks for your point out.I fixed it and checked that all tests passed in C++, python, scilab octave except matlab (sorry, but I don't have a matlab license).Best regardsTetsuo2021年4月19日(月) 19:42 Konstantinos Poulios <firstname.lastname@example.org>:Dear Tetsuo,Could I get you to update some uses of the old pstress and pstrain brick names in the following files?model_linear_elasticity.rstdemo_elasticity.mI hope I haven't missed any other affected files.Otherwise if all tests run successfully, then it is fine for me to merge the branch.Best regardsKostasOn Fri, Apr 16, 2021 at 1:29 PM Tetsuo Koyama <email@example.com> wrote:Dear Yves and KostasThanks for your comments.I updated the method names.Please review it.Best regards,Tetsuo2021年4月16日(金) 17:37 Yves Renard <Yves.Renard@insa-lyon.fr>:
I also think that these name changes are convenient.
On 10/04/2021 06:57, Tetsuo Koyama wrote:
Dear Kostas and Yves
@Kostas Thank you for your comment. It is a good point.
I am a fan of adding brick at the end of the methods.
If you don't mind I will fix the name of these methods in this branch.
Best regards Tetsuo
2021年4月10日(土) 4:24 Konstantinos Poulios <firstname.lastname@example.org>:
Dear Tetsuo and Yves
@Tetsuo thanks for this interface functions. I would like to use this opportunity to discuss about the word "brick" in the naming of our functions adding PDE term matrices. Traditionally, "brick" was only used at the end of the function name. More recently, Yves started skipping "brick" from some of the newer terms, which I think is fine. Now we have a mix with names including "brick" and some without. Apart from that, there are 3 functions that do not follow the old naming convention at all:
add_lumped_mass_brick_for_first_orderI would like to avoid this kind of inconsistencies in the naming so that all functions for adding a PDE matrix either have "brick" at the end of their name or that they do not include it at all.
For Tetsuo's function I would suggest one of
Both in c++ and the interfaces.
What do you think?
On Fri, Apr 9, 2021 at 11:23 AM Tetsuo Koyama <email@example.com> wrote:
Dear GetFEM project
I added the lumped mass for first order to the python interface.Could you merge devel-tetsuo-add_lumped_mass_python_interface_squash ?
-- Yves Renard (Yves.Renard@insa-lyon.fr) tel : (33) 04.72.43.87.08 INSA-Lyon 20, rue Albert Einstein 69621 Villeurbanne Cedex, FRANCE http://math.univ-lyon1.fr/~renard ---------
|[Prev in Thread]||Current Thread||[Next in Thread]|